aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-06 16:45:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:03 +0000
commit174c1bf0e3862663d334dd2e74b6fc1a8a2ceae0 (patch)
treec06e2e764a9b93fc2f5aa5ff7aad1b3acb62b943
parentd4a202cab6eaa22c10a68bbf5ce1fb0b32eb053f (diff)
downloadguix-174c1bf0e3862663d334dd2e74b6fc1a8a2ceae0.tar
guix-174c1bf0e3862663d334dd2e74b6fc1a8a2ceae0.tar.gz
gnu: Add python-pytest-html.
* gnu/packages/python-check.scm (python-pytest-html): New variable. Change-Id: Idbfd00f31f8064b978e5a15a825b191cf4b5515c
-rw-r--r--gnu/packages/python-check.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 9fcbed3c57..7fc4fe1a83 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -888,6 +888,38 @@ namespace which can be used to register helper functions without requiring
someone to import them in their actual tests to use them.")
(license license:asl2.0)))
+(define-public python-pytest-html
+ (package
+ (name "python-pytest-html")
+ (version "4.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest_html" version))
+ (sha256
+ (base32 "01vgd2bbk3n9wcqzx9dv72qgkx684l8cp92n9c3ll3w0wn51x83h"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; It requires running browser for selenium.
+ #~(list "--ignore=testing/test_integration.py"
+ "--ignore=testing/test_e2e.py")))
+ (native-inputs
+ (list python-hatchling
+ python-hatch-vcs
+ python-assertpy
+ python-beautifulsoup4
+ python-pytest))
+ (propagated-inputs
+ (list python-jinja2
+ python-pytest-metadata))
+ (home-page "https://github.com/pytest-dev/pytest-html")
+ (synopsis "Pytest plugin for generating HTML reports")
+ (description
+ "This packages provides a pytest plugin for generating HTML reports.")
+ (license license:mpl2.0)))
+
(define-public python-pytest-metadata
(package
(name "python-pytest-metadata")