aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <me@jeandudey.tech>2022-06-22 20:29:05 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2022-06-25 17:55:49 +0200
commitaae46e30d953dd24a5e04ffa5a397c70ef42b945 (patch)
treee9782ddb92692a3e5adb17454e4d83977e02ca63
parent8a35479f26098699cb1407580e5231b4f51c8b36 (diff)
downloadguix-aae46e30d953dd24a5e04ffa5a397c70ef42b945.tar
guix-aae46e30d953dd24a5e04ffa5a397c70ef42b945.tar.gz
gnu: ppp: Fix cross-compilation.
* gnu/packages/samba.scm (ppp)[arguments]: Use G-Expressions. Remove unused substitution. Fix OpenSSL and libpcap include paths. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/samba.scm34
1 files changed, 17 insertions, 17 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index b775ad905c..208dca94ca 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2020 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -469,23 +470,22 @@ key-value pair databases and a real LDAP database.")
"1bhhksdclsnkw54a517ndrw55q5zljjbh9pcqz1z4a2z2flxpsgk"))))
(build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no check target
- #:make-flags '("CC=gcc")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-Makefile
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((libc (assoc-ref inputs "libc"))
- (openssl (assoc-ref inputs "openssl"))
- (libpcap (assoc-ref inputs "libpcap")))
- (substitute* "pppd/Makefile.linux"
- (("/usr/include/crypt\\.h")
- (string-append libc "/include/crypt.h"))
- (("/usr/include/openssl")
- (string-append openssl "/include/openssl"))
- (("/usr/include/pcap-bpf.h")
- (string-append libpcap "/include/pcap-bpf.h")))
- #t))))))
+ (list #:tests? #f ;; No "check" target
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target)))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-Makefile
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((openssl (assoc-ref inputs "openssl"))
+ (libpcap (assoc-ref inputs "libpcap")))
+ (substitute* "pppd/Makefile.linux"
+ (("/usr/include/openssl")
+ (string-append openssl "/include"))
+ (("-DPPP_FILTER")
+ (string-append "-DPPP_FILTER -I" libpcap "/include")))
+ (substitute* "pppd/pppcrypt.h"
+ (("des\\.h") "openssl/des.h")))
+ #t)))))
(inputs
(list libpcap
(@ (gnu packages tls) openssl)))