aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-06-21 14:14:08 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-23 23:20:56 +0200
commita5d8630e158718325c7804e8043b92013626158c (patch)
treee3102221451e3062d58f28a473d00a9a7ce162b3
parentdbebe6c0b4b8a6e3c44e1a85cb3365df8d8d565c (diff)
downloadguix-a5d8630e158718325c7804e8043b92013626158c.tar
guix-a5d8630e158718325c7804e8043b92013626158c.tar.gz
gnu: polybar: Update to 3.6.3.
* gnu/packages/wm.scm (polybar): Update to 3.6.3. [phases]: Add patch-config-path for polybar to find its default configuration file in the store. [inputs]: Add libuv, required to build polybar. [native-inputs]: Remove python-2, no longer needed. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm20
1 files changed, 14 insertions, 6 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 35b79919b1..ab97266f72 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1469,19 +1469,29 @@ its size
(define-public polybar
(package
(name "polybar")
- (version "3.5.7")
+ (version "3.6.3")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/polybar/polybar/releases/"
"download/" version "/polybar-" version ".tar.gz"))
(sha256
- (base32 "1nr386jdlm8qkbdf23w7lyvbfhr362s90f957fawnyi1finhw8bk"))))
+ (base32 "19azx5dpfyfh0pv4q2fcrf4p7a0pc5d13m7lnv3qy8376mbmhmzj"))))
(build-system cmake-build-system)
(arguments
;; Test is disabled because it requires downloading googletest from the
;; Internet.
- '(#:tests? #f))
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Make polybar find its default configuration file in the
+ ;; store.
+ (add-after 'unpack 'patch-config-path
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("/etc") (string-append #$output "/etc")))
+ (substitute* "src/utils/file.cpp"
+ (("\"/etc\"") (string-append "\"" #$output "/etc\""))))))))
(inputs
(list alsa-lib
cairo
@@ -1489,6 +1499,7 @@ its size
jsoncpp
libmpdclient
libnl
+ libuv
libxcb
pulseaudio
xcb-proto
@@ -1500,9 +1511,6 @@ its size
(native-inputs
`(("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx) ; for the manual
- ;; XXX: "python" input must be located after "python-2", or the package
- ;; fails to build with "missing required python module: xcbgen".
- ("python-2" ,python-2) ; lib/xpp depends on python 2
("python" ,python))) ; xcb-proto depends on python 3
(home-page "https://polybar.github.io/")
(synopsis "Fast and easy-to-use status bar")