aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-06-23 23:48:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-06-23 23:48:26 +0200
commita119c9b27b57d915ee42db1ddca423fc410a4b90 (patch)
treefcacf7a03d34390c56ab1533946d41c29b161b92
parent000b710cee6f402e79f2d3f988039bb793a0b215 (diff)
downloadguix-a119c9b27b57d915ee42db1ddca423fc410a4b90.tar
guix-a119c9b27b57d915ee42db1ddca423fc410a4b90.tar.gz
gnu: Add emacs-straight-el.
* gnu/packages/emacs-xyz.scm (emacs-straight-el): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5493e8ed1..c60bb2b4c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -31710,6 +31710,60 @@ headlines, keywords, tables and source blocks.")
"@code{emacs-pyimport} manages python imports from Emacs via @code{python-pyflakes}.")
(license license:gpl3+)))) ; License is in pyimport.el
+(define-public emacs-straight-el
+ (let ((commit "4517e118ee43f849f708025dbb2cf4f281793121")
+ (revision "0"))
+ (package
+ (name "emacs-straight-el")
+ (version (git-version "0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/raxod502/straight.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0idhgh203rac9c046286gir9rq0lgnlllzj4b4hrjpd3idg9v0r8"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:tests? #t
+ #:test-command
+ #~(list "emacs" "-Q" "--batch"
+ "-L" "."
+ "--load" "ert"
+ "--load" "tests/straight-test.el"
+ "--eval" "(progn (require 'straight-ert-print-hack) (ert-run-tests-batch-and-exit))")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-git-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (make-file-writable "straight.el")
+ (substitute* "straight.el"
+ (("\"git\"")
+ (string-append "\""
+ (search-input-file inputs "/bin/git")
+ "\"")))))
+ (add-after 'check 'delete-tests
+ ;; "tests" directory includes bogus ".el" files that can make
+ ;; `patch-el-files' phase fail.
+ (lambda _
+ (delete-file-recursively "tests"))))))
+ (native-inputs
+ (list texinfo))
+ (inputs
+ (list git))
+ (propagated-inputs
+ (list emacs-magit))
+ (home-page "https://github.com/raxod502/straight.el/")
+ (synopsis "Purely functional package manager for the Emacs hacker")
+ (description
+ "@code{emacs-straight-el} is a purely functional package manager for the Emacs
+hacker.")
+ (license license:expat))))
+
(define-public emacs-osm
(package
(name "emacs-osm")