aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-05-10 00:35:14 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 23:03:31 -0400
commit575dffef01e98cccde5accdf54f2af6b75b58053 (patch)
treed25bf1a301b54649fa1a2dc647d4af8dc615dbc3
parent0cee62d45ad0ff73860a4e0524bc6cd89263c018 (diff)
downloadguix-575dffef01e98cccde5accdf54f2af6b75b58053.tar
guix-575dffef01e98cccde5accdf54f2af6b75b58053.tar.gz
gnu: containerd: Fix patch-paths build phase.
* gnu/packages/docker.scm (containerd)[arguments]: Add 'patch-paths phases after 'unpack because 'chdir doesn't exist. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/docker.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 07731886ae..5c0f4d496d 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2020 Jesse Dowell <jessedowell@gmail.com>
;;; Copyright © 2021 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2022 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -190,7 +191,7 @@ Python without keeping their credentials in a Docker configuration file.")
`(#:import-path "github.com/containerd/containerd"
#:phases
(modify-phases %standard-phases
- (add-after 'chdir 'patch-paths
+ (add-after 'unpack 'patch-paths
(lambda* (#:key inputs import-path outputs #:allow-other-keys)
(with-directory-excursion (string-append "src/" import-path)
(substitute* "runtime/v1/linux/runtime.go"