aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 23:26:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 23:54:29 -0400
commit487070c4254524e1ad00c0c29acaa7b3d71cdda4 (patch)
tree9b77f2dee997c544f972a2821713c3f9b3e2058a
parent168a4955a320ebdf6fd2d3c630cd1aaea7ca6064 (diff)
downloadguix-487070c4254524e1ad00c0c29acaa7b3d71cdda4.tar
guix-487070c4254524e1ad00c0c29acaa7b3d71cdda4.tar.gz
gnu: docker: Honor TESTS? and please guix lint.
* gnu/packages/docker.scm (docker)[phases]{patch-paths}: Split long lines. {check}: Honor TESTS?. [synopsis]: Do not start synopsis with package name.
-rw-r--r--gnu/packages/docker.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 02fb003c36..ae4ee419af 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -348,7 +348,8 @@ built-in registry server of Docker.")
(string-append "DefaultCommand = \""
(search-input-file inputs "/sbin/runc")
"\"\n")))
- (substitute* "vendor/github.com/containerd/containerd/runtime/v1/linux/runtime.go"
+ (substitute* "vendor/github.com/containerd/containerd/\
+runtime/v1/linux/runtime.go"
(("defaultRuntime[ \t]*=.*")
(string-append "defaultRuntime = \""
(search-input-file inputs "/sbin/runc")
@@ -385,7 +386,8 @@ built-in registry server of Docker.")
(string-append "expectedInitPath: \""
(search-input-file inputs "/bin/tini-static")
"\"")))
- (substitute* "vendor/github.com/moby/buildkit/executor/runcexecutor/executor.go"
+ (substitute* "vendor/github.com/moby/buildkit/executor/\
+runcexecutor/executor.go"
(("var defaultCommandCandidates = .*")
(string-append "var defaultCommandCandidates = []string{\""
(search-input-file inputs "/sbin/runc") "\"}")))
@@ -534,19 +536,20 @@ built-in registry server of Docker.")
;; dockerd instead.
(invoke "hack/make.sh" "dynbinary")))
(replace 'check
- (lambda _
- ;; The build process generated a file because the environment
- ;; variable "AUTO_GOPATH" was set. Use it.
- (setenv "GOPATH" (string-append (getcwd) "/.gopath"))
- ;; ".gopath/src/github.com/docker/docker" is a link to the current
- ;; directory and chdir would canonicalize to that.
- ;; But go needs to have the uncanonicalized directory name, so
- ;; store that.
- (setenv "PWD" (string-append (getcwd)
- "/.gopath/src/github.com/docker/docker"))
- (with-directory-excursion ".gopath/src/github.com/docker/docker"
- (invoke "hack/test/unit"))
- (setenv "PWD" #f)))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; The build process generated a file because the environment
+ ;; variable "AUTO_GOPATH" was set. Use it.
+ (setenv "GOPATH" (string-append (getcwd) "/.gopath"))
+ ;; ".gopath/src/github.com/docker/docker" is a link to the current
+ ;; directory and chdir would canonicalize to that.
+ ;; But go needs to have the uncanonicalized directory name, so
+ ;; store that.
+ (setenv "PWD" (string-append
+ (getcwd) "/.gopath/src/github.com/docker/docker"))
+ (with-directory-excursion ".gopath/src/github.com/docker/docker"
+ (invoke "hack/test/unit"))
+ (setenv "PWD" #f))))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -580,7 +583,7 @@ built-in registry server of Docker.")
(native-inputs
(list eudev ; TODO: Should be propagated by lvm2 (.pc -> .pc)
go gotestsum pkg-config))
- (synopsis "Docker container component library, and daemon")
+ (synopsis "Container component library and daemon")
(description "This package provides a framework to assemble specialized
container systems. It includes components for orchestration, image
management, secret management, configuration management, networking,