aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 22:49:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-23 22:49:08 -0400
commit39b118776bbbaed049f8bcafa27bde30d9d0b2f6 (patch)
tree69c0b308a601ccd3b9ab3edb92a1fba3b34f005a
parent06902a6766f089e4da812876ddcf33e7ba8afce0 (diff)
downloadguix-39b118776bbbaed049f8bcafa27bde30d9d0b2f6.tar
guix-39b118776bbbaed049f8bcafa27bde30d9d0b2f6.tar.gz
gnu: ibus-anthy: Modernize.
* gnu/packages/ibus.scm (ibus-anthy)[phases]: Delete trailing #t and adjust to use search-input-file and search-input-directory. [native-inputs]: Use new style. [inputs]: Likewise.
-rw-r--r--gnu/packages/ibus.scm38
1 files changed, 21 insertions, 17 deletions
diff --git a/gnu/packages/ibus.scm b/gnu/packages/ibus.scm
index 9c0c4903ca..74e0e45110 100644
--- a/gnu/packages/ibus.scm
+++ b/gnu/packages/ibus.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2021 Songlin Jiang <hollowman@hollowman.ml>
;;; Copyright © 2021 Taiju HIGASHI <higashi@taiju.info>
+;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -329,25 +330,28 @@ Chinese pinyin input methods.")
(modify-phases %standard-phases
(add-after 'install 'wrap-programs
(lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (for-each
- (lambda (prog)
- (wrap-program (string-append out "/libexec/" prog)
- `("GUIX_PYTHONPATH" ":" prefix
- (,(getenv "GUIX_PYTHONPATH")))
- `("GI_TYPELIB_PATH" ":" prefix
- (,(getenv "GI_TYPELIB_PATH")
- ,(string-append out "/lib/girepository-1.0")))))
- '("ibus-engine-anthy" "ibus-setup-anthy"))
- #t))))))
+ (for-each (lambda (prog)
+ (wrap-program (search-input-file
+ outputs (string-append "libexec/" prog))
+ `("GUIX_PYTHONPATH" ":" prefix
+ (,(getenv "GUIX_PYTHONPATH")))
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH")
+ ,(search-input-directory
+ inputs "lib/girepository-1.0")))))
+ '("ibus-engine-anthy" "ibus-setup-anthy")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list gettext-minimal
+ `(,glib "bin")
+ intltool
+ pkg-config
+ python))
(inputs
- (list anthy gtk+ ibus gobject-introspection python-pygobject))
+ (list anthy
+ gtk+
+ ibus
+ gobject-introspection
+ python-pygobject))
(synopsis "Anthy Japanese language input method for IBus")
(description "IBus-Anthy is an engine for the input bus \"IBus\"). It
adds the Anthy Japanese language input method to IBus. Because most graphical