aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-24 09:27:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-06-24 09:30:22 -0400
commit0c6960c17aac890e871ff41dae7c0cde1d741c9f (patch)
tree79294ba14cc49b4d0cd5a069e69ec05e46e3caf3
parentcc7a3055aaf5b7da46f5d730de10965e1043d8e4 (diff)
downloadguix-0c6960c17aac890e871ff41dae7c0cde1d741c9f.tar
guix-0c6960c17aac890e871ff41dae7c0cde1d741c9f.tar.gz
gnu: python-jedi: Fix build.
* gnu/packages/python-xyz.scm (python-jedi) [phases]{fix-completion-test}: New phase. {check}: Delete trailing #t.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a2178bf5d5..f8ca2242ed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17038,12 +17038,19 @@ scans through a file and detects issues.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-completion-test
+ (lambda _
+ ;; This resolves a failure in the 'test_completion' test (see:
+ ;; https://github.com/davidhalter/jedi/issues/1824).
+ ;; TODO: Remove after a new release is made (currently: 0.18.1).
+ (substitute* "test/completion/lambdas.py"
+ (("\\[a for a in \\[1,2\\] if lambda: 3\\]\\[0\\]")
+ "[a for a in [1,2] if (lambda: 3)][0]"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(setenv "HOME" "/tmp")
- (invoke "python" "-m" "pytest" "-vv"))
- #t)))))
+ (invoke "python" "-m" "pytest" "-vv")))))))
(native-inputs
(list python-colorama python-docopt python-pytest))
(propagated-inputs