aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2022-10-09 02:08:24 -0300
committerLudovic Courtès <ludo@gnu.org>2022-10-09 22:32:14 +0200
commitbdb13dfd29e7b6028f23ca5faa4983848375e7c5 (patch)
treed8bb356c8079c99a2c3690836eda3a5f18f2d0f6
parentfa3ba0143fee0b8ccbd0371cc37c1435d4f2a68f (diff)
downloadguix-bdb13dfd29e7b6028f23ca5faa4983848375e7c5.tar
guix-bdb13dfd29e7b6028f23ca5faa4983848375e7c5.tar.gz
gnu: public-inbox: Update to 1.9.0.
The patch is included in version 1.9.0, so remove it from Guix. On i686-linux, test t/pop3d.t fails unless the File::FcntlLock module is present so add it. * gnu/packages/patches/public-inbox-fix-spawn-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/mail.scm (public-inbox)[version]: Change to 1.9.0. [source]: Update hash. Remove patch. [inputs]: Add perl-file-fcntllock if target is x86-32. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/mail.scm67
-rw-r--r--gnu/packages/patches/public-inbox-fix-spawn-test.patch43
3 files changed, 36 insertions, 75 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9a1aad300e..5ce3db8a92 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1684,7 +1684,6 @@ dist_patch_DATA = \
%D%/packages/patches/psm-disable-memory-stats.patch \
%D%/packages/patches/psm-ldflags.patch \
%D%/packages/patches/psm-repro.patch \
- %D%/packages/patches/public-inbox-fix-spawn-test.patch \
%D%/packages/patches/pulseaudio-fix-mult-test.patch \
%D%/packages/patches/pulseaudio-longer-test-timeout.patch \
%D%/packages/patches/pulseview-qt515-compat.patch \
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..82126f5a3b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4141,7 +4141,7 @@ Git and exports them in maildir format or to an MDA through a pipe.")
(define-public public-inbox
(package
(name "public-inbox")
- (version "1.8.0")
+ (version "1.9.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -4149,9 +4149,8 @@ Git and exports them in maildir format or to an MDA through a pipe.")
(commit (string-append "v" version))))
(sha256
(base32
- "0xni1l54v1z3p0zb52807maay0yqabp8jgf5iras5zmhgjyk3swz"))
- (file-name (git-file-name name version))
- (patches (search-patches "public-inbox-fix-spawn-test.patch"))))
+ "0cgvxg0f32nvb3079x46gjkfis4bc98s6nx6kl8rm90kmb1kxkx9"))
+ (file-name (git-file-name name version))))
(build-system perl-build-system)
(arguments
`(#:imported-modules (,@%perl-build-system-modules
@@ -4227,33 +4226,39 @@ Git and exports them in maildir format or to an MDA through a pipe.")
(list ;; For testing.
lsof openssl tini))
(inputs
- (list bash-minimal
- curl
- git
- perl-dbd-sqlite
- perl-dbi
- perl-email-address-xs
- perl-email-mime-contenttype
- perl-email-mime
- perl-email-simple
- perl-net-server
- perl-plack-middleware-deflater
- perl-plack-middleware-reverseproxy
- perl-plack
- perl-search-xapian
- perl-socket-msghdr
- perl-timedate
- perl-uri-escape
- perl-inline-c
- perl-parse-recdescent
- perl-linux-inotify2
- ;; FIXME: Perl modules are unable to find the config file for highlight
- ;; https://issues.guix.gnu.org/48033#4
- ;; ("highlight" ,highlight)
- ;; For testing.
- perl-ipc-run
- perl-xml-feed
- xapian))
+ (append
+ (if (target-x86-32?)
+ ;; Required by test t/pop3d.t, otherwise fails with
+ ;; “sizeof(off_t)=8 requires File::FcntlLock”.
+ (list perl-file-fcntllock)
+ '())
+ (list bash-minimal
+ curl
+ git
+ perl-dbd-sqlite
+ perl-dbi
+ perl-email-address-xs
+ perl-email-mime-contenttype
+ perl-email-mime
+ perl-email-simple
+ perl-net-server
+ perl-plack-middleware-deflater
+ perl-plack-middleware-reverseproxy
+ perl-plack
+ perl-search-xapian
+ perl-socket-msghdr
+ perl-timedate
+ perl-uri-escape
+ perl-inline-c
+ perl-parse-recdescent
+ perl-linux-inotify2
+ ;; FIXME: Perl modules are unable to find the config file for highlight
+ ;; https://issues.guix.gnu.org/48033#4
+ ;; ("highlight" ,highlight)
+ ;; For testing.
+ perl-ipc-run
+ perl-xml-feed
+ xapian)))
(home-page "https://public-inbox.org/README.html")
(synopsis "Archive mailing lists in Git repositories")
(description
diff --git a/gnu/packages/patches/public-inbox-fix-spawn-test.patch b/gnu/packages/patches/public-inbox-fix-spawn-test.patch
deleted file mode 100644
index 2739b1974d..0000000000
--- a/gnu/packages/patches/public-inbox-fix-spawn-test.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 5593489d9c3ce22b1942f35c7ebb0e06fcf2bfa8 Mon Sep 17 00:00:00 2001
-From: Thiago Jung Bauermann <bauermann@kolabnow.com>
-Date: Fri, 10 Jun 2022 12:39:18 -0300
-Subject: [PATCH] t/spawn: Find invalid PID to try to join its process group
-
-In the container used to build packages of the GNU Guix distribution, PID 1
-runs as the same user as the test so this spawn that should fail actually
-succeeds.
-
-Fix the problem by going through different PIDs and picking one that
-either doesn't exist or we aren't allowed to signal.
----
-
-This patch is taken from the public-inbox repository and will appear in the
-release after v1.8.
-
- t/spawn.t | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/t/spawn.t b/t/spawn.t
-index 6168c1f6171c..5fc99a2a101c 100644
---- a/t/spawn.t
-+++ b/t/spawn.t
-@@ -24,7 +24,18 @@ SKIP: {
- is(waitpid($pid, 0), $pid, 'waitpid succeeds on spawned process');
- is($?, 0, 'true exited successfully');
- pipe(my ($r, $w)) or BAIL_OUT;
-- $pid = eval { spawn(['true'], undef, { pgid => 1, 2 => $w }) };
-+
-+ # Find invalid PID to try to join its process group.
-+ my $wrong_pgid = 1;
-+ for (my $i=0x7fffffff; $i >= 2; $i--) {
-+ if (kill(0, $i) == 0) {
-+ $wrong_pgid = $i;
-+ last;
-+ }
-+ }
-+
-+ # Test spawn behavior when it can't join the requested process group.
-+ $pid = eval { spawn(['true'], undef, { pgid => $wrong_pgid, 2 => $w }) };
- close $w;
- my $err = do { local $/; <$r> };
- # diag "$err ($@)";