aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2022-09-26 09:27:03 +0200
committerAndrew Tropin <andrew@trop.in>2022-10-13 11:09:29 +0400
commit910f2b5d883703c706ac40c0e1dbaba0f85ead71 (patch)
tree815cf83e7493eda6e0d81a4a63a7a095e952ae93
parent4ab434958b8e97c73e8900ebb48721de11fa3c81 (diff)
downloadguix-910f2b5d883703c706ac40c0e1dbaba0f85ead71.tar
guix-910f2b5d883703c706ac40c0e1dbaba0f85ead71.tar.gz
gnu: Add ydotool.
* gnu/packages/xdisorg.scm (ydotool): New variable. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/xdisorg.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 2533744633..09f13a33d7 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3168,3 +3168,24 @@ that support @samp{wlr-gamma-control-unstable-v1}. It is also known as a blue
light filter or night light.")
(license license:expat)))
+(define-public ydotool
+ (package
+ (name "ydotool")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ReimuNotMoe/ydotool")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h19dh7kai0iikssr7sq0wfkh0sb18dylyfg7c3dkwc158cdg9cr"))))
+ (build-system cmake-build-system)
+ (arguments '(#:tests? #f)) ; no tests
+ (native-inputs (list scdoc))
+ (home-page "https://github.com/ReimuNotMoe/ydotool")
+ (synopsis "Generic Linux command-line automation tool (no X!)")
+ (description "@code{ydotool} is a Linux command-line tool that simulates
+keyboard input, mouse actions, etc. programmatically or manually.")
+ (license license:agpl3+)))