aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Albers <thomas@thomaslabs.org>2022-10-11 15:08:34 +0200
committerChristopher Baines <mail@cbaines.net>2022-10-13 11:08:09 +0100
commit8559b70031599b4db215a988fe2a91df06c9e382 (patch)
tree2b27626466d9e4f93ab6c93b44554258710ac525
parentaabd7a05260773d1968e4cb69d80a22b15e869cd (diff)
downloadguix-8559b70031599b4db215a988fe2a91df06c9e382.tar
guix-8559b70031599b4db215a988fe2a91df06c9e382.tar.gz
gnu: Add hiredis.
* gnu/packages/databases.scm (hiredis): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/databases.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..f42ac3bfa5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@
;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2494,6 +2495,31 @@ sets, bitmaps and hyperloglogs.")
(home-page "https://redis.io/")
(license license:bsd-3)))
+(define-public hiredis
+ (package
+ (name "hiredis")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/redis/hiredis")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ ;; needed for testing
+ (list redis))
+ (synopsis "Minimalistic C client library for the Redis database")
+ (description "This package provides a library for sending commands and
+receiving replies to and from a Redis server. It comes with a synchronous
+API, asynchronous API and reply parsing API. Only the binary-safe Redis
+protocol is supported.")
+ (home-page "https://github.com/redis/hiredis")
+ (license license:bsd-3)))
+
(define-public ruby-redis
(package
(name "ruby-redis")