aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-10-12 23:28:09 -0500
committerChristopher Baines <mail@cbaines.net>2022-10-13 11:08:13 +0100
commit7db94d8e549df8fbf0a83368440d1dc155b51575 (patch)
treefe69856bff2b71c38e188da95db7c4908f761f6d
parent8559b70031599b4db215a988fe2a91df06c9e382 (diff)
downloadguix-7db94d8e549df8fbf0a83368440d1dc155b51575.tar
guix-7db94d8e549df8fbf0a83368440d1dc155b51575.tar.gz
gnu: Add ghc-open-browser.
* gnu/packages/haskell-xyz.scm (ghc-open-browser): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/haskell-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index db653f8c93..70fdffdc0b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages databases)
#:use-module (gnu packages emacs)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages gl)
#:use-module (gnu packages graphviz)
#:use-module (gnu packages gtk)
@@ -16118,6 +16119,33 @@ data Dec a
pages.")
(license license:bsd-3)))
+(define-public ghc-open-browser
+ (package
+ (name "ghc-open-browser")
+ (version "0.2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (hackage-uri "open-browser" version))
+ (sha256
+ (base32
+ "0rna8ir2cfp8gk0rd2q60an51jxc08lx4gl0liw8wwqgh1ijxv8b"))))
+ (build-system haskell-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-xdg-open
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((xdg-open (assoc-ref inputs "xdg-utils")))
+ (substitute* "lib/Web/Browser/Linux.hs"
+ (("xdg-open")
+ (search-input-file inputs "/bin/xdg-open")))))))))
+ (inputs (list xdg-utils))
+ (home-page "https://github.com/rightfold/open-browser")
+ (synopsis "Open a web browser from Haskell")
+ (description "Haskell library for opening the web browser.")
+ (license license:bsd-3)))
+
(define-public ghc-singleton-bool
(package
(name "ghc-singleton-bool")