aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormirlan <milranmike@protonmail.com>2022-10-05 17:56:19 +0900
committerLudovic Courtès <ludo@gnu.org>2022-10-11 16:05:32 +0200
commit68d79a8b60a1a564a8425de8220fb65dc79ba9ee (patch)
tree6bbbb70c96117de452b3bab132c2d72ed68112d2
parentf5fd7414747f275d09c7b3ce3552331e723db633 (diff)
downloadguix-68d79a8b60a1a564a8425de8220fb65dc79ba9ee.tar
guix-68d79a8b60a1a564a8425de8220fb65dc79ba9ee.tar.gz
gnu: Add libskk.
* gnu/packages/language.scm (libskk): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/language.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 182ef2f8c2..937954a1ad 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2022 Milran <milranmike@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -923,3 +924,31 @@ noun phrases, verb phrases, etc.).")
analysis (pitch, formant, intensity, ...), speech synthesis, labelling, segmenting
and manipulation.")
(license license:gpl2+)))
+
+(define-public libskk
+ (package
+ (name "libskk")
+ (version "1.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ueno/libskk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y279pcgs3jrsi9vzx086xhz9jbz23dqqijp4agygc9ackp9sxy5"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf
+ automake
+ gettext-minimal
+ gobject-introspection
+ libtool
+ pkg-config
+ vala))
+ (inputs (list libgee json-glib libxkbcommon))
+ (home-page "https://github.com/ueno/libskk")
+ (synopsis "Dealing with Japanese kana-to-kanji conversion")
+ (description
+ "libskk is a library to deal with Japanese kana-to-kanji conversion method.")
+ (license license:gpl3+)))