aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2022-10-10 15:08:35 +0000
committerChristopher Baines <mail@cbaines.net>2022-10-11 12:05:59 +0100
commit59911ae29442aba18bcb53233e793d8f3d264504 (patch)
treec4553e4af512a9a0522884671c5b452aadad0bfc
parentfcbe9cf6f8dc0a1bdc120ffe299b0435743bf632 (diff)
downloadguix-59911ae29442aba18bcb53233e793d8f3d264504.tar
guix-59911ae29442aba18bcb53233e793d8f3d264504.tar.gz
gnu: Update guile-eris to 1.0.0.
* gnu/packages/guile-xyz.scm (guile-eris): Update to 1.0.0. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/guile-xyz.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1760ba331e..379d9aa264 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4485,15 +4485,15 @@ tools.")
(define-public guile-eris
(package
(name "guile-eris")
- (version "0.2.0")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
(uri (git-reference
- (url "https://inqlab.net/git/eris.git")
+ (url "https://codeberg.org/eris/guile-eris.git")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
- (sha256 (base32 "1ijglmwkdy1l87gj429qfjis0v8b1zlxhbyfhx5za8664h68nqka"))))
+ (sha256 (base32 "0d4wbjwwaxk0zn5gjhl86qhvk1aisgzp1vnvy4xbvrv5ydqpgyqm"))))
(build-system gnu-build-system)
(arguments '())
(native-inputs
@@ -4502,17 +4502,18 @@ tools.")
pkg-config
texinfo
;; test dependency
- guile-srfi-180))
+ guile-srfi-180
+ guile-quickcheck))
(inputs (list guile-3.0))
(propagated-inputs
(list guile-sodium))
(synopsis "Guile implementation of the Encoding for Robust Immutable Storage (ERIS)")
(description
- "Guile-ERIS is the reference implementation of the Encoding for Robust
-Immutable Storage (ERIS). ERIS allows arbitrary content to be encoded into
-uniformly sized, encrypted blocks that can be reassembled using a short
-read-capability.")
- (home-page "https://inqlab.net/git/eris.git")
+ "Guile-ERIS is a Guile implementation of the @url{http://purl.org/eris,
+Encoding for Robust Immutable Storage (ERIS)}. ERIS allows arbitrary content
+to be encoded into uniformly sized, encrypted blocks that can be reassembled
+using a short read-capability.")
+ (home-page "https://codeberg.org/eris/guile-eris")
(license license:gpl3+)))
(define-public guile-r6rs-protobuf