aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-03 01:10:57 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-11 16:05:32 +0200
commit49ed67692d9ef9e7f262c264a5be10620ae695eb (patch)
tree3eda0ea99f00ff4c29ecfe4ea0e390332a7ba841
parentac338620bc63e03cfaeafb445901716231c32be2 (diff)
downloadguix-49ed67692d9ef9e7f262c264a5be10620ae695eb.tar
guix-49ed67692d9ef9e7f262c264a5be10620ae695eb.tar.gz
gnu: python-pydyf: Update to 0.3.0.
* gnu/packages/pdf.scm (python-pydyf): Update to 0.3.0. [arguments]: Add phases to replace build and install phases. [native-inputs]: Add python-flit-core, python-pypa-build. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/pdf.scm20
1 files changed, 16 insertions, 4 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8c661d9f12..430857bf30 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2019 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2019,2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -727,24 +727,36 @@ extracting content or merging files.")
(define-public python-pydyf
(package
(name "python-pydyf")
- (version "0.1.2")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pydyf" version))
(sha256
- (base32 "0b30g3hhxw1bg18r9ax85i1dkg8vy1y1wzas0bg0bxblh7j5sbqy"))))
+ (base32 "18q43g5d9455msipcgd5fvnh8m4a2rz189slzfg80yycjw66rshs"))))
(build-system python-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
+ (replace 'build
+ (lambda _
+ (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+ (replace 'install
+ (lambda _
+ (let ((whl (car (find-files "dist" "\\.whl$"))))
+ (invoke "pip" "--no-cache-dir" "--no-input"
+ "install" "--no-deps" "--prefix" #$output whl))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
(invoke "pytest" "-vv" "-c" "/dev/null")))))))
(propagated-inputs (list python-pillow))
- (native-inputs (list ghostscript python-pytest))
+ (native-inputs
+ (list ghostscript
+ python-flit-core
+ python-pypa-build
+ python-pytest))
(home-page "https://github.com/CourtBouillon/pydyf")
(synopsis "Low-level PDF generator")
(description "@code{pydyf} is a low-level PDF generator written in Python