aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-12-07 13:54:21 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-12-12 12:37:06 +0530
commite200de5457262877cc4bc13bd2723004a2c89963 (patch)
treeaa904b5674475a637984c99b4b2bbc6a0c671ea6
parentb2fb40de984cf2f523ac08edc04d41b7d4c01058 (diff)
downloadguix-e200de5457262877cc4bc13bd2723004a2c89963.tar
guix-e200de5457262877cc4bc13bd2723004a2c89963.tar.gz
gnu: Add chirp.
* gnu/packages/ham-radio.scm (chirp): New variable.
-rw-r--r--gnu/packages/ham-radio.scm35
1 files changed, 33 insertions, 2 deletions
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
index 0f96553c65..b73671c8bc 100644
--- a/gnu/packages/ham-radio.scm
+++ b/gnu/packages/ham-radio.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,9 +20,13 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages libusb)
#:use-module (gnu packages pkg-config)
- #:use-module (guix build-system cmake))
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml)
+ #:use-module (guix build-system cmake)
+ #:use-module (guix build-system python))
(define-public rtl-sdr
(package
@@ -50,3 +54,30 @@
cheap software defined radio, since the chip allows transferring the raw I/Q
samples to the host. @code{rtl-sdr} provides drivers for this purpose.")
(license license:gpl2+)))
+
+(define-public chirp
+ (package
+ (name "chirp")
+ (version "20181205")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://trac.chirp.danplanet.com/chirp_daily/daily-"
+ version "/chirp-daily-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1cp280b95j39xaxs50zn55jigg7pyfpm9n098hmsyxrplqn8z43c"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python2-libxml2" ,python2-libxml2)
+ ("python2-pygtk" ,python2-pygtk)
+ ("python2-pyserial" ,python2-pyserial)))
+ (arguments
+ `(#:python ,python-2))
+ (home-page "https://chirp.danplanet.com")
+ (synopsis "Cross-radio programming tool")
+ (description "Chirp is a cross-radio programming tool. It supports a
+growing list of radios across several manufacturers and allows transferring of
+memory contents between them.")
+ (license (list license:gpl3+
+ license:lgpl3+)))) ; chirp/elib_intl.py