aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-13 13:56:41 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-14 16:14:46 +0000
commitbd208a13ef4c203cf9035c0ccf454a60c1949c58 (patch)
treefba168ea15b4331a96ee937c85e2738b8ff5c6be
parentadb158b7396cbdcda347fa298978408e531a03fd (diff)
downloadguix-bd208a13ef4c203cf9035c0ccf454a60c1949c58.tar
guix-bd208a13ef4c203cf9035c0ccf454a60c1949c58.tar.gz
gnu: ghc-call-stack-boot: Make it a hidden package.
This package doesn't sound like it should be directly used, so hide it. * gnu/packages/haskell.scm (ghc-call-stack-boot): Use hidden-package to hide the package.
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 57435dca07..8d0e2aef69 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5069,10 +5069,11 @@ call stacks with different versions of the compiler.")
;; This is used as an input to ghc-hunit. We cannot use ghc-call-stack there,
;; because it depends on ghc-nanospec, which depends on ghc-hunit.
(define-public ghc-call-stack-boot
- (package
- (inherit ghc-call-stack)
- (arguments '(#:tests? #f))
- (inputs '())))
+ (hidden-package
+ (package
+ (inherit ghc-call-stack)
+ (arguments '(#:tests? #f))
+ (inputs '()))))
(define-public ghc-statevar
(package