aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 20:04:53 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:32:39 +0100
commitbc9319f42ba2f9048c7790a0bab9cd447a18e95e (patch)
treebbdf2f3b9aefe0466f9eb5ff11e0d062919b0852
parenta5bfedb45c9f4f06719200140973761547955e94 (diff)
downloadguix-bc9319f42ba2f9048c7790a0bab9cd447a18e95e.tar
guix-bc9319f42ba2f9048c7790a0bab9cd447a18e95e.tar.gz
gnu: chez-web: Replace texlive input with minimal texlive-union.
* gnu/packages/chez.scm (chez-web)[native-inputs]: Replace texlive with minimal texlive-union.
-rw-r--r--gnu/packages/chez.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index c7858147cf..7cae5f27c2 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -279,7 +279,15 @@ and 32-bit PowerPC architectures.")
(build-system gnu-build-system)
(native-inputs
`(("chez-scheme" ,chez-scheme)
- ("texlive" ,texlive)))
+ ("ghostscript" ,ghostscript)
+ ("texlive" ,(texlive-union (list texlive-latex-oberdiek
+ texlive-generic-epsf
+ texlive-metapost
+ texlive-fonts-charter
+ texlive-generic-pdftex
+ texlive-context-base
+ texlive-fonts-cm
+ texlive-tex-plain)))))
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output)
(string-append "DOCDIR=" %output "/share/doc/"
@@ -289,6 +297,12 @@ and 32-bit PowerPC architectures.")
#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
+ (add-before 'build 'set-HOME
+ (lambda _
+ ;; FIXME: texlive-union does not find the built
+ ;; metafonts, so it tries to generate them in HOME.
+ (setenv "HOME" "/tmp")
+ #t))
;; This package has a custom "bootstrap" script that
;; is meant to be run from the Makefile.
(delete 'bootstrap)