aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-11 17:49:39 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:27 +0100
commitae218b75f6e1ea47f11b10008d8815638674bdf7 (patch)
treeb7722d42bc80fcbe76c18c488a32247ce5792743
parentf6c19fe8ce9ba767ceb62b9f2ef3b8fb3b5ac8c5 (diff)
downloadguix-ae218b75f6e1ea47f11b10008d8815638674bdf7.tar
guix-ae218b75f6e1ea47f11b10008d8815638674bdf7.tar.gz
gnu: python-billiard: Update to 3.5.0.5.
This is to enable updating python-celery. * gnu/packages/python.scm (python-billiard): Update to 3.5.0.5. [native-inputs]: Remove python-nose, add python-case and python-pytest.
-rw-r--r--gnu/packages/python.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 53ab6d35ea..df142353cb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8382,17 +8382,18 @@ RabbitMQ messaging server is the most popular implementation.")
(define-public python-billiard
(package
(name "python-billiard")
- (version "3.3.0.23")
+ (version "3.5.0.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "billiard" version))
(sha256
(base32
- "02wxsc6bhqvzh8j6w758kvgqbnj14l796mvmrcms8fgfamd2lak9"))))
+ "03msmapj3s5zgqk87d646mafz7a01h5bm2wijalgpi0s80ks5na2"))))
(build-system python-build-system)
(native-inputs
- `(("python-nose" ,python-nose)))
+ `(("python-case" ,python-case)
+ ("python-pytest" ,python-pytest)))
(home-page "https://github.com/celery/billiard")
(synopsis
"Python multiprocessing fork with improvements and bugfixes")