aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 17:13:40 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:32:39 +0100
commit9b405aeaa292d7d2171340af6bd5218c72a10f8c (patch)
treefc9479c121aa245465601e19dbf211e316d37c23
parent315956895173bdbe54f18ac8938ad1b70f7ef93b (diff)
downloadguix-9b405aeaa292d7d2171340af6bd5218c72a10f8c.tar
guix-9b405aeaa292d7d2171340af6bd5218c72a10f8c.tar.gz
gnu: hypre: Replace texlive input with minimal texlive-union.
* gnu/packages/maths.scm (hypre)[native-inputs]: Replace texlive with minimal texlive-union.
-rw-r--r--gnu/packages/maths.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 96a1ecb043..ad6aacf9c9 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3707,7 +3707,13 @@ set.")
`(("doc++" ,doc++)
("netpbm" ,netpbm)
("perl" ,perl) ;needed to run 'ppmquant' during tests
- ("texlive" ,texlive) ;full package required for fonts
+ ("texlive" ,(texlive-union (list texlive-generic-xypic
+ texlive-fonts-xypic
+ texlive-latex-hyperref
+ texlive-latex-oberdiek
+ texlive-generic-ifxetex
+ texlive-latex-url
+ texlive-bibtex)))
("ghostscript" ,ghostscript)))
(inputs
`(("blas" ,openblas)
@@ -3724,6 +3730,12 @@ set.")
"--with-blas")
#:phases
(modify-phases %standard-phases
+ (add-before 'build 'set-HOME
+ (lambda _
+ ;; FIXME: texlive-union does not find the built
+ ;; metafonts, so it tries to generate them in HOME.
+ (setenv "HOME" "/tmp")
+ #t))
(add-before 'configure 'chdir-src
(lambda _ (chdir "src")))
(replace 'configure
@@ -3738,7 +3750,7 @@ set.")
configure-flags)))))))
(add-after 'build 'build-docs
(lambda _
- (zero? (system* "make" "-Cdocs" "pdf" "html"))))
+ (invoke "make" "-Cdocs" "pdf" "html")))
(replace 'check
(lambda _
(setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/hypre/lib"))