aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-12-12 19:35:05 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-12-12 19:40:34 +0800
commit7b046b1bdc0b1cbc50428d4e08136a110f0a12af (patch)
tree0e49901cad4a52f7c59e3a1ddc022f8cd6f1728c
parent3a48d055383c6838177ffcdc9fd544372bb2d722 (diff)
downloadguix-7b046b1bdc0b1cbc50428d4e08136a110f0a12af.tar
guix-7b046b1bdc0b1cbc50428d4e08136a110f0a12af.tar.gz
gnu: zathura-pdf-mupdf: Fix dependencies.
* gnu/packages/pdf.scm (zathura-pdf-mupdf)[inputs]: Add mujs. [arguments]: Pass 'link-external' to the configure flags. Patch 'meson.build' to include mujs as 'build_dependencies'.
-rw-r--r--gnu/packages/pdf.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4170e4a0ae..c34a0bc8ca 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -438,6 +438,7 @@ using the DjVuLibre library.")
(inputs
`(("jbig2dec" ,jbig2dec)
("libjpeg" ,libjpeg)
+ ("mujs", mujs)
("mupdf" ,mupdf)
("openjpeg" ,openjpeg)
("openssl" ,openssl)
@@ -447,7 +448,18 @@ using the DjVuLibre library.")
`(#:tests? #f ; package does not contain tests
#:configure-flags (list (string-append "-Dplugindir="
(assoc-ref %outputs "out")
- "/lib/zathura"))))
+ "/lib/zathura")
+ "-Dlink-external=true")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'add-mujs-to-dependencies
+ (lambda _
+ ;; Add mujs to the 'build_dependencies'.
+ (substitute* "meson.build"
+ (("^ libopenjp2 = dependency.*" x)
+ (string-append x " mujs = cc.find_library('mujs')\n"))
+ (("^ libopenjp2")
+ " libopenjp2, mujs")))))))
(home-page "https://pwmt.org/projects/zathura-pdf-mupdf/")
(synopsis "PDF support for zathura (mupdf backend)")
(description "The zathura-pdf-mupdf plugin adds PDF support to zathura