aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:19:18 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:26 +0100
commit7600513a8a29f69f041f20cbbad0b68ccd17ad64 (patch)
tree04145298209d0eb30efdf18f308d6b66944d59c7
parent42140fd434a333d0565617471b51323d6815ee13 (diff)
downloadguix-7600513a8a29f69f041f20cbbad0b68ccd17ad64.tar
guix-7600513a8a29f69f041f20cbbad0b68ccd17ad64.tar.gz
gnu: Add python-pytest-sugar.
This is required to update python-amqp and python-kombu. * gnu/packages/check.scm (check): New variable.
-rw-r--r--gnu/packages/check.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 937e4e094c..5bf849d666 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1414,6 +1414,30 @@ normally the case.")
(define-public python2-pytest-subtesthack
(package-with-python2 python-pytest-subtesthack))
+(define-public python-pytest-sugar
+ (package
+ (name "python-pytest-sugar")
+ (version "0.9.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-sugar" version))
+ (sha256
+ (base32
+ "1asq7yc4g8bx2sn7yy974mhc9ywvaihasjab4inkirdwn9s7mn7w"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-packaging" ,python-packaging)
+ ("python-pytest" ,python-pytest)
+ ("python-termcolor" ,python-termcolor)))
+ (home-page "https://pivotfinland.com/pytest-sugar/")
+ (synopsis "Plugin for pytest that changes the default look and feel")
+ (description
+ "@code{pytest-sugar} is a plugin for py.test that changes the default
+look and feel of py.test, using a progress bar and showing failures and errors
+instantly.")
+ (license license:bsd-3)))
+
(define-public python-hypothesis
(package
(name "python-hypothesis")