aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 16:39:13 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:32:38 +0100
commit547ab6506f6afed3f58596e2df981d1cd6a21205 (patch)
tree6c9f62c05c4fdf87df1b91c77a10083cad37f30a
parent8a2cfc7bea37fd5cc5d384ac16d7cd3bd5603ab9 (diff)
downloadguix-547ab6506f6afed3f58596e2df981d1cd6a21205.tar
guix-547ab6506f6afed3f58596e2df981d1cd6a21205.tar.gz
gnu: Add texlive-generic-xypic.
* gnu/packages/tex.scm (texlive-generic-xypic): New variable.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 916aa54d58..88959adcc1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4940,3 +4940,38 @@ used inside tables and moving arguments such as footnotes and section
titles.")
;; No version of the GPL is specified.
(license license:gpl3+)))
+
+(define-public texlive-generic-xypic
+ (package
+ (name "texlive-generic-xypic")
+ (version (number->string %texlive-revision))
+ (source
+ (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/generic/xypic"))
+ (revision %texlive-revision)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "1g5cyxwdfznq4lk9zl6fkjkapmhmwd2cm4m5aibxj20qgwnaggfz"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/generic/xypic")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "https://www.ctan.org/pkg/xypic")
+ (synopsis "Flexible diagramming macros for TeX")
+ (description
+ "A package for typesetting a variety of graphs and diagrams with TeX.
+Xy-pic works with most formats (including LaTeX, AMS-LaTeX, AMS-TeX, and plain
+TeX).")
+ (license license:gpl3+)))