aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2018-12-14 20:11:58 +0800
committerArun Isaac <arunisaac@systemreboot.net>2018-12-15 11:52:35 +0530
commit4803ce1d6c7b994c3fa105b85cb2417756e11a27 (patch)
tree378e89fd31c5be565265bb3a3e696f59add9c997
parent0a2872eeaa139c467115f33c0ab2a6a1f6b78ccf (diff)
downloadguix-4803ce1d6c7b994c3fa105b85cb2417756e11a27.tar
guix-4803ce1d6c7b994c3fa105b85cb2417756e11a27.tar.gz
gnu: Add emacs-posframe.
* gnu/packages/emacs.scm (emacs-posframe): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 4f2fc94d36..2f3236e6e6 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6674,6 +6674,28 @@ containing words from the rime project.")
and cangjie.")
(license license:gpl2+)))
+(define-public emacs-posframe
+ (package
+ (name "emacs-posframe")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/posframe-" version ".el"))
+ (sha256
+ (base32
+ "1h8vvxvsg41vc1nnglqjs2q0k1yzfsn72skga9s76qa3zxmx6kds"))))
+ (build-system emacs-build-system)
+ ;; emacs-minimal does not include the function font-info
+ (arguments `(#:emacs ,emacs))
+ (home-page "https://github.com/tumashu/posframe")
+ (synopsis "Pop a posframe (a child frame) at point")
+ (description "@code{emacs-posframe} can pop a posframe at point. A
+posframe is a child frame displayed within its root window's buffer.
+@code{emacs-posframe} is fast and works well with CJK languages.")
+ (license license:gpl3+)))
+
(define-public emacs-el2org
(package
(name "emacs-el2org")