aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:01:16 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-12-14 23:32:39 +0100
commit1e0f2ae0283949ee2237ca0e6013b54acdc2b7a6 (patch)
treeae546a7ad15366bc874b7bf5c771592319ed6aeb
parentbc9319f42ba2f9048c7790a0bab9cd447a18e95e (diff)
downloadguix-1e0f2ae0283949ee2237ca0e6013b54acdc2b7a6.tar
guix-1e0f2ae0283949ee2237ca0e6013b54acdc2b7a6.tar.gz
gnu: chez-sockets: Replace texlive input with minimal texlive-union.
* gnu/packages/chez.scm (chez-sockets)[native-inputs]: Replace texlive with minimal texlive-union.
-rw-r--r--gnu/packages/chez.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 7cae5f27c2..10601f0bfa 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -345,7 +345,7 @@ programming in Scheme.")
(native-inputs
`(("chez-scheme" ,chez-scheme)
("chez-web" ,chez-web)
- ("texlive" ,texlive)))
+ ("texlive" ,(texlive-union (list texlive-generic-pdftex)))))
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -361,11 +361,16 @@ programming in Scheme.")
(string-append var chez-h)))
#t)))
(add-before 'build 'tangle
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "TEXINPUTS"
+ (string-append
+ (getcwd) ":"
+ (assoc-ref inputs "chez-web") "/share/texmf-local/tex/generic:"
+ ":"))
;; just using "make" tries to build the .c files before
;; they are created.
- (and (zero? (system* "make" "sockets"))
- (zero? (system* "make")))))
+ (and (invoke "make" "sockets")
+ (invoke "make"))))
(replace 'build
(lambda* (#:key outputs inputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))