aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFeng Shu <tumashu@163.com>2018-12-14 19:57:17 +0800
committerArun Isaac <arunisaac@systemreboot.net>2018-12-15 11:52:35 +0530
commit1827e8db9342ca43af355eaa87acddbc807d72cf (patch)
tree508252c33945fce9545ca195fd670558c7e299dd
parent4803ce1d6c7b994c3fa105b85cb2417756e11a27 (diff)
downloadguix-1827e8db9342ca43af355eaa87acddbc807d72cf.tar
guix-1827e8db9342ca43af355eaa87acddbc807d72cf.tar.gz
gnu: emacs-pyim: Update to 1.8.
* gnu/packages/emacs.scm (emacs-pyim): Update to 1.8. [source]: Use git-fetch. [propagated-inputs]: Remove emacs-pos-tip. Add emacs-posframe. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 2f3236e6e6..98b1c6ddd3 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6652,22 +6652,23 @@ containing words from the rime project.")
(define-public emacs-pyim
(package
(name "emacs-pyim")
- (version "1.6.4")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/tumashu/pyim/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "0hfg8q9hcjifvnlghw2g94dfxfirms2psq2ghqb28fhkf0lks13r"))))
+ (version "1.8")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tumashu/pyim")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16rma4cv7xgky0g3x4an27v30jdi6i1sqw43cl99zhkqvp43l3f9"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-async" ,emacs-async)
("emacs-pyim-basedict" ,emacs-pyim-basedict)
("emacs-popup" ,emacs-popup)
- ("emacs-pos-tip" ,emacs-pos-tip)))
+ ("emacs-posframe" ,emacs-posframe)))
(home-page "https://github.com/tumashu/pyim")
(synopsis "Chinese input method")
(description "Chinese input method which supports quanpin, shuangpin, wubi