aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:19:59 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:26 +0100
commit053f3d48578e10e8e4be348f3ad6de539cfa2455 (patch)
tree8a2a9f3889ac78f9d387638e0a4262bb914cb7bb
parent7600513a8a29f69f041f20cbbad0b68ccd17ad64 (diff)
downloadguix-053f3d48578e10e8e4be348f3ad6de539cfa2455.tar
guix-053f3d48578e10e8e4be348f3ad6de539cfa2455.tar.gz
gnu: Add python-serpent.
This is required for python-pyro4, which is needed to update python-amqp and python-kombu. * gnu/packages/python.scm (python-serpent): New variable.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 20b07d3e27..4e40e3677f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -908,6 +908,29 @@ version identifier.")
(define-public python2-semantic-version
(package-with-python2 python-semantic-version))
+(define-public python-serpent
+ (package
+ (name "python-serpent")
+ (version "1.27")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "serpent" version))
+ (sha256
+ (base32
+ "04p9dsrm5pv8vhk3flvih55kgvlzpi38hlaykdiakddmgwqw93bg"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/irmen/Serpent")
+ (synopsis "Serializer for literal Python expressions")
+ (description
+ "Serpent provides ast.literal_eval() compatible object tree
+serialization. It serializes an object tree into bytes (utf-8 encoded string)
+that can be decoded and then passed as-is to ast.literal_eval() to rebuild it
+as the original object tree. As such it is safe to send serpent data to other
+machines over the network for instance (because only safe literals are
+encoded).")
+ (license license:expat)))
+
(define-public python-setuptools
(package
(name "python-setuptools")