aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-21 18:27:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 00:20:10 +0200
commite626984639c535dbd191744438b4bcae796768d5 (patch)
tree973d532eb4f8e355e50e692aa59a7052cf96cfa3
parentda6f345c7104dfd39911ec9f27b19107ae63ef32 (diff)
downloadguix-e626984639c535dbd191744438b4bcae796768d5.tar
guix-e626984639c535dbd191744438b4bcae796768d5.tar.gz
gnu: libsmpeg: Return #t from all phases.
* gnu/packages/video.scm (libsmpeg)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/video.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d76ab881d2..61b1b0228c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2196,10 +2196,11 @@ Other features include a live preview and live streaming.")
"18yfkr70lr1x1hc8snn2ldnbzdcc7b64xmkqrfk8w59gpg7sl1xn"))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'autogen.sh
- (lambda _
- (zero? (system* "sh" "autogen.sh")))))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autogen.sh
+ (lambda _
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))