aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 16:56:36 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 00:20:11 +0200
commitbb6c3d2332d74e268f5d48b39b92b97cea1acab3 (patch)
tree58e4e39be032d5a4e81058417097fb62de3d01f8
parent1fe5791d8dd78914941d9ef370ef9e49808c9c9e (diff)
downloadguix-bb6c3d2332d74e268f5d48b39b92b97cea1acab3.tar
guix-bb6c3d2332d74e268f5d48b39b92b97cea1acab3.tar.gz
gnu: libsemanage: Return #t from all phases.
* gnu/packages/selinux.scm (libsemanage)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/selinux.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 9562123bda..c56a991d99 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -201,10 +202,10 @@ the core SELinux management utilities.")
(lambda _ (chdir ,name) #t))
(add-after 'build 'pywrap
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "pywrap" make-flags))))
+ (apply invoke "make" "pywrap" make-flags)))
(add-after 'install 'install-pywrap
(lambda* (#:key make-flags #:allow-other-keys)
- (zero? (apply system* "make" "install-pywrap" make-flags))))))))
+ (apply invoke "make" "install-pywrap" make-flags)))))))
(inputs
`(("libsepol" ,libsepol)
("libselinux" ,libselinux)