aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-06-17 00:54:08 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-20 23:47:08 +0200
commitaddda2eeb3ecd3ce411993a4638ca79559132923 (patch)
tree93a4afe3743a31c56db71841b96a4a6c189da262
parent414ee4edc9e6fcadba366072a7ebabf3e3c6f26a (diff)
downloadguix-addda2eeb3ecd3ce411993a4638ca79559132923.tar
guix-addda2eeb3ecd3ce411993a4638ca79559132923.tar.gz
gnu: Add emacs-mu4e-conversation.
* gnu/packages/emacs.scm (emacs-mu4e-conversation): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 219358bbdb..da3a3f6a41 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -11291,3 +11291,34 @@ file.")
"@code{wgrep-helm} allows you to edit a @code{helm-grep-mode} buffer and
apply those changes to the file buffer.")
(license license:gpl3+))))
+
+(define-public emacs-mu4e-conversation
+ (let ((commit "b60d6bd27d7220c3dd041ff2a090e29f2166a319"))
+ (package
+ (name "emacs-mu4e-conversation")
+ (version (git-version "20180615" "1" commit))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gitlab.com/Ambrevar/mu4e-conversation/"
+ "repository/archive.tar.gz?ref="
+ commit))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "0x8kmi0rmbaaxn5zicm1f9yb8ynxi8074hi2n0rvymlfpxbpn0ma"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("mu" ,mu)))
+ (home-page
+ "https://gitlab.com/Ambrevar/mu4e-conversation")
+ (synopsis
+ "Show a complete thread in a single buffer")
+ (description
+ "This package offers an alternate view to mu4e e-mail display. It
+shows all e-mails of a thread in a single view, where each correspondant has
+their own face. Threads can be displayed linearly (in which case e-mails are
+displayed in chronological order) or as an Org document where the node tree
+maps the thread tree.")
+ (license license:gpl3+))))