aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 14:34:31 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 14:39:54 +0200
commitacb1c72c1eceffee2427b01b51299d8151aa180a (patch)
tree8f16bbcf44df2c2f438ab94f6957255e4379924d
parent00fca594da4c63a976e1c67ec3caab47f2a38d87 (diff)
downloadguix-acb1c72c1eceffee2427b01b51299d8151aa180a.tar
guix-acb1c72c1eceffee2427b01b51299d8151aa180a.tar.gz
gnu: neofetch: Remove dead code.
Turns out that's most of it. * gnu/packages/admin.scm (neofetch)[arguments]: Remove all custom phases.
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 1 insertions, 21 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index af9cdbfbcc..fa8e60087b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2407,27 +2407,7 @@ tool for remote execution and deployment.")
(list (string-append "PREFIX=" %output))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-target-directories
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "Makefile"
- (("\\$\\(DESTDIR\\)/etc/")
- "$(PREFIX)/etc/"))
- (substitute* "neofetch"
- (("\"/etc/neofetch")
- (string-append "\"" out "/etc/neofetch"))
- (("\"/usr/share/neofetch")
- (string-append "\"" out "/share/neofetch"))))
- #t))
- (delete 'configure) ; no configure script
- (replace 'install
- (lambda* (#:key make-flags outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (doc (string-append out "/share/doc/" ,name "-" ,version))
- (etc (string-append doc "/examples/etc")))
- (zero? (apply system* `("make" ,@make-flags
- ,(string-append "SYSCONFDIR=" etc)
- "install")))))))))
+ (delete 'configure)))) ; no configure script
(home-page "https://github.com/dylanaraps/neofetch")
(synopsis "System info script")
(description "Neofetch is a CLI system information tool written in Bash.