aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-21 19:26:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 00:20:11 +0200
commit863501b723adc496d49ee329c035648020f43b2f (patch)
treec30b42cb716d90a0ff37c790142921062b093d7d
parent2cd8e6e066cdf730a55d0604f0180286db4604ed (diff)
downloadguix-863501b723adc496d49ee329c035648020f43b2f.tar
guix-863501b723adc496d49ee329c035648020f43b2f.tar.gz
gnu: vpnc-scripts: Return #t from all phases.
* gnu/packages/vpn.scm (vpnc-scripts)[arguments]: Substitute INVOKE for SYSTEM*. Return #t rather than undefined from phases.
-rw-r--r--gnu/packages/vpn.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index fb06196ec4..5043265db8 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -161,7 +161,7 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
(delete 'configure) ; no configure script
(replace 'build
(lambda _
- (zero? (system* "gcc" "-o" "netunshare" "netunshare.c"))))
+ (invoke "gcc" "-o" "netunshare" "netunshare.c")))
(replace 'install
;; There is no Makefile; manually install the relevant files.
(lambda* (#:key outputs #:allow-other-keys)
@@ -193,7 +193,8 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
"sed"
"which")))))
(find-files (string-append out "/etc/vpnc/vpnc-script")
- "^vpnc-script"))))))
+ "^vpnc-script"))
+ #t))))
#:tests? #f)) ; no tests
(home-page "http://git.infradead.org/users/dwmw2/vpnc-scripts.git")
(synopsis "Network configuration scripts for Cisco VPN clients")