aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-21 18:26:57 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-22 00:20:10 +0200
commit52fb5b3aee026dadd4bd79ca6a81035ca34575eb (patch)
tree61c3087f292df408ae6504f1cc4d9e9d95abc3f8
parente626984639c535dbd191744438b4bcae796768d5 (diff)
downloadguix-52fb5b3aee026dadd4bd79ca6a81035ca34575eb.tar
guix-52fb5b3aee026dadd4bd79ca6a81035ca34575eb.tar.gz
gnu: vapoursynth: Return #t from all phases.
* gnu/packages/video.scm (vapoursynth)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/video.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 61b1b0228c..3ab1ed7bad 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1765,10 +1765,9 @@ capabilities.")
(arguments
'(#:phases
(modify-phases %standard-phases
- (add-after
- 'unpack 'autogen
- (lambda _
- (zero? (system* "sh" "autogen.sh")))))))
+ (add-after 'unpack 'autogen
+ (lambda _
+ (invoke "sh" "autogen.sh"))))))
(home-page "http://www.vapoursynth.com/")
(synopsis "Video processing framework")
(description "VapourSynth is a C++ library and Python module for video