aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-11-05 14:48:39 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-11-05 18:44:10 +0100
commit546ddefc762ced5fa90d812ddb84bd9d08d250c4 (patch)
tree87fe64314e0d7c643fb0e5a9fd272749f5549b37
parent1ce9759407f000a1333ef97a70b347b9cd4b8a4c (diff)
downloadguix-546ddefc762ced5fa90d812ddb84bd9d08d250c4.tar
guix-546ddefc762ced5fa90d812ddb84bd9d08d250c4.tar.gz
gnu: Add go-golang-zx2c4-com-wireguard.
* gnu/packages/golang.scm (go-golang-zx2c4-com-wireguard): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d4de1f5c45..66d734a261 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5979,3 +5979,33 @@ tests.")
used like a user interface for humans, to read and edit before passing the
JSON data to the machine.")
(license license:expat)))
+
+(define-public go-golang-zx2c4-com-wireguard
+ (package
+ (name "go-golang-zx2c4-com-wireguard")
+ (version "0.0.20200320")
+ (source
+ (origin
+ (method git-fetch)
+ ;; NOTE: module URL is a redirect
+ ;; target: git.zx2c4.com/wireguard-go
+ ;; source: golang.zx2c4.com/wireguard
+ (uri (git-reference
+ (url "https://git.zx2c4.com/wireguard-go/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fy4qsss3i3pkq1rpgjds4aipbwlh1dr9hbbf7jn2a1c63kfks0r"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "golang.zx2c4.com/wireguard"))
+ (propagated-inputs
+ `(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-golang-org-x-text" ,go-golang-org-x-text)))
+ (home-page "https://git.zx2c4.com/wireguard")
+ (synopsis "Implementation of WireGuard in Go")
+ (description "This package is a Go Implementation of WireGuard.")
+ (license license:expat)))