aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-10-29 17:10:25 +0100
committerJulien Lepiller <julien@lepiller.eu>2020-11-05 18:43:59 +0100
commit336c9f0a81c9bc0ed0a2d3e0d050a677806c07c0 (patch)
tree6fad04c866805e16336d2370263f29cc62c10c59
parent251cb68342cc226245bdf301e767865e3ec275f7 (diff)
downloadguix-336c9f0a81c9bc0ed0a2d3e0d050a677806c07c0.tar
guix-336c9f0a81c9bc0ed0a2d3e0d050a677806c07c0.tar.gz
gnu: Add go-github-com-hashicorp-go-syslog.
* gnu/packages/golang.scm (go-github-com-hashicorp-go-syslog): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6ba735c4a2..ba75308a4a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5933,3 +5933,25 @@ tests.")
(description
"This package provides SCSS compiler support for Go applications.")
(license license:expat)))
+
+(define-public go-github-com-hashicorp-go-syslog
+ (package
+ (name "go-github-com-hashicorp-go-syslog")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hashicorp/go-syslog")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "09vccqggz212cg0jir6vv708d6mx0f9w5bxrcdah3h6chgmal6v1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/hashicorp/go-syslog"))
+ (home-page "https://github.com/hashicorp/go-syslog")
+ (synopsis "Golang syslog wrapper, cross-compile friendly")
+ (description "This package is a very simple wrapper around log/syslog")
+ (license license:expat)))