aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNoah Landis <noahlandis@posteo.net>2020-11-04 19:47:27 -0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-05 21:20:52 +0100
commit2d357136dcc66217d6aa94659708659d95eec345 (patch)
treec9b507fc598e86e3bd45133655647837e8c4388f
parentfe1cd098d2b83737e96f19438612291f5a9316e4 (diff)
downloadguix-2d357136dcc66217d6aa94659708659d95eec345.tar
guix-2d357136dcc66217d6aa94659708659d95eec345.tar.gz
gnu: Add emacs-nord-theme.
* gnu/packages/emacs-xyz.scm (emacs-nord-theme): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6caf50858a..77dd5642c2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -84,6 +84,7 @@
;;; Copyright © 2020 Zhu Zihao <all_but_last@163.com>
;;; Copyright © 2020 Adam Kandur <rndd@tuta.io>
;;; Copyright © 2020 Tim Howes <timhowes@lavabit.com>
+;;; Copyright © 2020 Noah Landis <noahlandis@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25281,3 +25282,25 @@ the TypeScript implementation.")
(description "This package provides an Emacs client for the Rocket.chat
service.")
(license license:expat))))
+
+(define-public emacs-nord-theme
+ (package
+ (name "emacs-nord-theme")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arcticicestudio/nord-emacs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "096f8cik4jz89bvkifwp3gm9iraqrd75ljy2q9js724v7yj88711"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.nordtheme.com/")
+ (synopsis "Low contrast arctic color theme for Emacs")
+ (description
+ "Nord is an arctic, north-bluish color scheme created for a clean and
+uncluttered design pattern to achieve optimal focus and readability for code
+syntax highlighting and UI components.")
+ (license license:expat)))