aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-04-15 23:57:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-04-16 00:45:57 -0400
commit1988ef21f82430d4b380dd4887160a902d8796fd (patch)
tree9de2a126878486cb0d11812b9ab430715cc12acd
parentbd21acf6c390e4fe87eb6053f0b5185d6ecbcf9f (diff)
downloadguix-1988ef21f82430d4b380dd4887160a902d8796fd.tar
guix-1988ef21f82430d4b380dd4887160a902d8796fd.tar.gz
gnu: linphone: Reformat code to respect coding style conventions.
* gnu/packages/linphone.scm (bcunit, belr, belcard, bcmatroska2, bzrtp) (belle-sip, mediastreamer2, msopenh264, mssilk, msamr): Adjust code formatting to meet the 80 characters line width convention, along with other minor cosmetic edits. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/linphone.scm136
1 files changed, 63 insertions, 73 deletions
diff --git a/gnu/packages/linphone.scm b/gnu/packages/linphone.scm
index e18d04bd06..779ddf8cb7 100644
--- a/gnu/packages/linphone.scm
+++ b/gnu/packages/linphone.scm
@@ -69,12 +69,11 @@
(arguments
'(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(synopsis "Belledonne Communications Unit Testing Framework")
- (description "BCUnit is a fork of the defunct project CUnit,
-with several fixes and patches applied. It is an unit testing
-framework for writing, administering, and running unit tests in C.")
+ (description "BCUnit is a fork of the defunct project CUnit, with several
+fixes and patches applied. It is an unit testing framework for writing,
+administering, and running unit tests in C.")
(home-page "https://gitlab.linphone.org/BC/public/bcunit")
(license license:lgpl2.0+)))
@@ -94,8 +93,7 @@ framework for writing, administering, and running unit tests in C.")
(arguments
'(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=OFF"))) ; Not required
+ (list "-DENABLE_STATIC=OFF"))) ; Not required
(inputs
`(("bcunit" ,bcunit)
("mbedtls" ,mbedtls-apache)))
@@ -121,14 +119,14 @@ Communications software like belle-sip, mediastreamer2 and linphone.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=OFF"))) ; Not required
+ (list "-DENABLE_STATIC=OFF"))) ; Not required
(inputs
`(("bctoolbox" ,bctoolbox)))
(synopsis "Belledonne Communications Language Recognition Library")
- (description "Belr is Belledonne Communications' language recognition library,
-written in C++11. It parses text inputs formatted according to a language
-defined by an ABNF grammar, such as the protocols standardized at IETF.")
+ (description "Belr is Belledonne Communications' language recognition
+library, written in C++11. It parses text inputs formatted according to a
+language defined by an ABNF grammar, such as the protocols standardized at
+IETF.")
(home-page "https://gitlab.linphone.org/BC/public/belr")
(license license:gpl3+)))
@@ -148,13 +146,13 @@ defined by an ABNF grammar, such as the protocols standardized at IETF.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=OFF"))) ; Not required
+ (list "-DENABLE_STATIC=OFF"))) ; Not required
(inputs
`(("bctoolbox" ,bctoolbox)
("belr" ,belr)))
(synopsis "Belledonne Communications VCard Library")
- (description "Belcard is a C++ library to manipulate VCard standard format.")
+ (description "Belcard is a C++ library to manipulate VCard standard
+format.")
(home-page "https://gitlab.linphone.org/BC/public/belcard")
(license license:gpl3+)))
@@ -177,16 +175,16 @@ defined by an ABNF grammar, such as the protocols standardized at IETF.")
(list
"-DENABLE_STATIC=NO"))) ; Not required
(synopsis "Belledonne Communications Media Container")
- (description "BcMatroska is a free and open standard multi-media
-container format. It can hold an unlimited number of video, audio,
-picture, or subtitle tracks in one file. ")
+ (description "BcMatroska is a free and open standard multi-media container
+format. It can hold an unlimited number of video, audio, picture, or subtitle
+tracks in one file. ")
(home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
(license
(list
- ;; That license applies for Core C and LibEBML2.
+ ;; For Core C and LibEBML2.
;; https://www.matroska.org/node/47
license:bsd-4
- ;; That license applies for LibMatroska2.
+ ;; For LibMatroska2.
;; https://www.matroska.org/node/47
license:lgpl2.1+))))
@@ -206,8 +204,7 @@ picture, or subtitle tracks in one file. ")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(synopsis "Belledonne Communications G729 Codec")
(description "BcG729 is an implementation of both encoder and decoder of
the ITU G729 speech codec. The library written in C 99 is fully portable and
@@ -233,8 +230,7 @@ such as conferencing.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(native-inputs
`(("dot" ,graphviz)
("doxygen" ,doxygen)))
@@ -262,16 +258,15 @@ implements the RFC 3550 standard.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO")))
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(inputs
`(("bctoolbox" ,bctoolbox)
("sqlite3" ,sqlite)
("xml2" ,libxml2)))
(synopsis "Belledonne Communications ZRTP Library")
- (description "BZRTP is an implementation of ZRTP keys exchange
-protocol, written in C. It is fully portable and can be executed on many
-platforms including both ARM and x86.")
+ (description "BZRTP is an implementation of ZRTP keys exchange protocol,
+written in C. It is fully portable and can be executed on many platforms
+including both ARM and x86.")
(home-page "https://gitlab.linphone.org/BC/public/bzrtp")
(license license:gpl2+)))
@@ -291,16 +286,15 @@ platforms including both ARM and x86.")
(arguments
`(#:tests? #f ; Requires network access
#:configure-flags
- (list
- "-DENABLE_STATIC=NO")
+ (list "-DENABLE_STATIC=NO") ; Not required
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch
(lambda _
(substitute* "src/CMakeLists.txt"
- ;; ANTLR would use multithreaded DFA generation
- ;; otherwise--which would not be reproducible.
- (("-Xmultithreaded ") ""))
+ ;; ANTLR would use multithreaded DFA generation otherwise,
+ ;; which would not be reproducible.
+ (("-Xmultithreaded ") ""))
#t)))))
(inputs
`(("antlr3" ,antlr3-3.3)
@@ -333,12 +327,11 @@ API. It also comprises a simple HTTP/HTTPS client implementation.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO" ; Not required
- "-DENABLE_STRICT=NO" ; Would otherwise treat warnings as err
- "-DENABLE_BV16=NO" ; Not available
- "-DCMAKE_C_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\""
- "-DCMAKE_CXX_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\"")
+ (list "-DENABLE_STATIC=NO" ; Not required
+ "-DENABLE_STRICT=NO" ; Would otherwise treat warnings as err
+ "-DENABLE_BV16=NO" ; Not available
+ "-DCMAKE_C_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\""
+ "-DCMAKE_CXX_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\"")
#:phases
(modify-phases %standard-phases
(add-after 'install 'separate-outputs
@@ -395,13 +388,12 @@ API. It also comprises a simple HTTP/HTTPS client implementation.")
("vpx" ,libvpx)
("x11" ,libx11)
("xv" ,libxv)
- ("zrtp", bzrtp)))
+ ("zrtp" ,bzrtp)))
(synopsis "Belledonne Communications Streaming Engine")
- (description "Mediastreamer2 is a powerful and lightweight
-streaming engine for telephony applications. This media processing
-and streaming toolkit is responsible for receiving and sending all
-multimedia streams in Linphone, including media capture, encoding and
-decoding, and rendering.")
+ (description "Mediastreamer2 is a powerful and lightweight streaming engine
+for telephony applications. This media processing and streaming toolkit is
+responsible for receiving and sending all multimedia streams in Linphone,
+including media capture, encoding and decoding, and rendering.")
(home-page "https://gitlab.linphone.org/BC/public/mediastreamer2")
(license license:gpl2+)))
@@ -421,16 +413,15 @@ decoding, and rendering.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
- (string-append (assoc-ref %build-inputs "gtk2")
- "/lib/gtk-2.0/include"))
- (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
- (string-append (assoc-ref %build-inputs "glib")
- "/lib/glib-2.0/include"))
- "-DENABLE_STATIC=NO" ; Not required
- "-DENABLE_STRICT=NO"
- "-DENABLE_GTK_UI=YES") ; for legacy UI
+ (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
+ (string-append (assoc-ref %build-inputs "gtk2")
+ "/lib/gtk-2.0/include"))
+ (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
+ (string-append (assoc-ref %build-inputs "glib")
+ "/lib/glib-2.0/include"))
+ "-DENABLE_STATIC=NO" ; Not required
+ "-DENABLE_STRICT=NO"
+ "-DENABLE_GTK_UI=YES") ; for legacy UI
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch
@@ -492,9 +483,9 @@ and video calls or instant messaging capabilities to an application.")
(add-after 'set-paths 'set-qt-rcc-source-date-override
(lambda _
;; This fixes a reproducibility problem where the Qt Resource
- ;; Compiler (RCC) includes timestamp of the its source files
+ ;; Compiler (RCC) includes timestamp of its source files
;; (see: https://reproducible-builds.org/docs/
- ;; deterministic-build-systems/#cmake-notes)
+ ;; deterministic-build-systems/#cmake-notes).
(setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
#t))
(add-after 'unpack 'fix-cmake-error
@@ -562,17 +553,18 @@ and video calls or instant messaging capabilities to an application.")
(origin
(method url-fetch)
(uri
- (string-append "https://gitlab.linphone.org/BC/public/msopenh264/commit/"
- "493d147d28c9a0f788ba4e50b47a1ce7b18bf326.diff"))
+ (string-append "https://gitlab.linphone.org/BC/public/msopenh264/"
+ "commit/493d147d28c9a0f788ba4e50b47a1ce7b18bf326"
+ ".diff"))
(file-name "msopenh264-openh264.patch")
(sha256
- (base32 "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
+ (base32
+ "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(inputs
`(("mediastreamer2" ,mediastreamer2)
("openh264" ,openh264)
@@ -599,14 +591,13 @@ mediastreamer2 based on the openh264 library.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO"))) ; Not required
+ (list "-DENABLE_STATIC=NO"))) ; Not required
(inputs
`(("mediastreamer2" ,mediastreamer2)
("ortp" ,ortp)))
(synopsis "Media Streamer SILK Codec")
- (description "MSSILK is a plugin of MediaStreamer, adding support for
-AMR codec. It is based on the Skype's SILK implementation.")
+ (description "MSSILK is a plugin of MediaStreamer, adding support for AMR
+codec. It is based on the Skype's SILK implementation.")
(home-page "https://gitlab.linphone.org/BC/public/mssilk")
(license license:gpl2+)))
@@ -627,7 +618,7 @@ AMR codec. It is based on the Skype's SILK implementation.")
`(#:tests? #f ; No test target
#:configure-flags
(list
- "-DENABLE_STATIC=NO")))
+ "-DENABLE_STATIC=NO"))) ; Not required
(inputs
`(("bctoolbox" ,bctoolbox)
("mediastreamer2" ,mediastreamer2)
@@ -654,16 +645,15 @@ WebRTC codec. It includes features from WebRTC, such as, iSAC and AECM.")
(arguments
`(#:tests? #f ; No test target
#:configure-flags
- (list
- "-DENABLE_STATIC=NO" ; Not required
- "-DENABLE_WIDEBAND=YES")))
+ (list "-DENABLE_STATIC=NO" ; Not required
+ "-DENABLE_WIDEBAND=YES")))
(inputs
`(("mediastreamer2" ,mediastreamer2)
("opencoreamr" ,opencore-amr)
("ortp" ,ortp)
("voamrwbenc" ,vo-amrwbenc)))
(synopsis "Media Streamer AMR Codec")
- (description "MSAMR is a plugin of MediaStreamer, adding support for
-AMR codec. It is based on the opencore-amr implementation.")
+ (description "MSAMR is a plugin of MediaStreamer, adding support for AMR
+codec. It is based on the opencore-amr implementation.")
(home-page "https://gitlab.linphone.org/BC/public/msamr")
(license license:gpl3+)))