aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-13 16:06:25 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:20 +0200
commit9b2850c8458747d6840538b1cf9a7f8b804bf17b (patch)
tree0817e85289b92742111ec564901f0dfb80574724
parentdc835e75ce2f8b192cddf9b20e3cffeb5722db6e (diff)
downloadguix-9b2850c8458747d6840538b1cf9a7f8b804bf17b.tar
guix-9b2850c8458747d6840538b1cf9a7f8b804bf17b.tar.gz
gnu: Add python-agate-sql.
* gnu/packages/wireservice.scm (python-agate-sql): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wireservice.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/wireservice.scm b/gnu/packages/wireservice.scm
index db17c55cd8..575b63792b 100644
--- a/gnu/packages/wireservice.scm
+++ b/gnu/packages/wireservice.scm
@@ -23,6 +23,7 @@
#:use-module (guix packages)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages databases)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sphinx)
@@ -122,3 +123,26 @@ charts now and don't care if they're perfect.")))
(description "Agate is a Python data analysis library. It is an
alternative to numpy and pandas that solves real-world problems with readable
code. Agate was previously known as journalism.")))
+
+(define-public python-agate-sql
+ (package
+ (inherit base-package)
+ (name "python-agate-sql")
+ (version "0.5.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wireservice/agate-sql.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16q0b211n5b1qmhzkfl2jr56lda0rvyh5j1wzw26h2n4pm4wxlx2"))))
+ (propagated-inputs
+ `(("python-agate" ,python-agate)
+ ("python-crate" ,python-crate)
+ ("python-sqlalchemy" ,python-sqlalchemy)))
+ (home-page "https://agate-sql.rtfd.org")
+ (synopsis "SQL read/write support to agate")
+ (description "@code{agatesql} uses a monkey patching pattern to add SQL
+support to all @code{agate.Table} instances.")))