aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph LaFreniere <joseph@lafreniere.xyz>2019-07-05 19:39:05 -0500
committerLudovic Courtès <ludo@gnu.org>2019-07-08 13:05:56 +0200
commit85630d8042ef0904f328dae809a658842e5858bb (patch)
tree251541c926dfda7cc2911f1a94475c765f3327e7
parent88a29b5cd33160a14fc9ef1f795de8d127b5fd8c (diff)
downloadguix-85630d8042ef0904f328dae809a658842e5858bb.tar
guix-85630d8042ef0904f328dae809a658842e5858bb.tar.gz
gnu: emacs-polymode: Update to 0.2.
* gnu/packages/emacs-xyz.scm (emacs-polymode): Update to 0.2. [source]: Change URL of Git repository to Polymode GitHub project. [homepage]: Change URL to polymode GitHub project. [description]: Realign text. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 30b6ccf673..706d60035d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9230,33 +9230,25 @@ contexts.
(define-public emacs-polymode
(package
(name "emacs-polymode")
- (version "0.1.5")
+ (version "0.2")
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/vspinu/polymode.git")
+ (url "https://github.com/polymode/polymode.git")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "0wwphs54jx48a3ca6x1qaz56j3j9bg4mv8g2akkffrzbdcb8sbc7"))))
+ "04v0gnzfsjb50bgly6kvpryx8cyzwjaq2llw4qv9ijw1l6ixmq3b"))))
(build-system emacs-build-system)
- (arguments
- `(#:include (cons* "^modes/.*\\.el$" %default-include)
- #:phases
- (modify-phases %standard-phases
- (add-after 'set-emacs-load-path 'add-modes-subdir-to-load-path
- (lambda _
- (setenv "EMACSLOADPATH"
- (string-append (getenv "EMACSLOADPATH")
- ":" (getcwd) "/modes" ":")))))))
- (home-page "https://github.com/vspinu/polymode")
+ (home-page "https://github.com/polymode/polymode")
(synopsis "Framework for multiple Emacs modes based on indirect buffers")
- (description "Polymode is an Emacs package that offers generic support
-for multiple major modes inside a single Emacs buffer. It is lightweight,
-object oriented and highly extensible. Creating a new polymode typically
-takes only a few lines of code. Polymode also provides extensible facilities
-for external literate programming tools for exporting, weaving and tangling.")
+ (description
+ "Polymode is an Emacs package that offers generic support for multiple
+major modes inside a single Emacs buffer. It is lightweight, object oriented
+and highly extensible. Creating a new polymode typically takes only a few
+lines of code. Polymode also provides extensible facilities for external
+literate programming tools for exporting, weaving and tangling.")
(license license:gpl3+)))
(define-public emacs-polymode-ansible