aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-13 16:06:21 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:20 +0200
commit450d5dc2893aad1511b280ff71a98840c29f64cb (patch)
treec55d2ee09c189dd7656671d63dbb1c75cd5a7521
parent0d5b7ea11f4b46197ede74e4b203244620dfd0f2 (diff)
downloadguix-450d5dc2893aad1511b280ff71a98840c29f64cb.tar
guix-450d5dc2893aad1511b280ff71a98840c29f64cb.tar.gz
gnu: Add python-crate.
* gnu/packages/databases.scm (python-crate): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/databases.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 561a3b3b12..b60bc69903 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -36,6 +36,7 @@
;;; Copyright © 2019 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -92,6 +93,7 @@
#:use-module (gnu packages popt)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages rdf)
#:use-module (gnu packages readline)
@@ -3080,3 +3082,24 @@ NumPy, and other traditional Python scientific computing packages.")
(define-public python2-pyarrow
(package-with-python2 python-pyarrow))
+
+(define-public python-crate
+ (package
+ (name "python-crate")
+ (version "0.23.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "crate" version))
+ (sha256
+ (base32
+ "0s3s7yg4m2zflg9q96aibwb5hizsn10ql63fsj6h5z624qkavnlp"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/crate/crate-python")
+ (synopsis "CrateDB Python client")
+ (description
+ "This package provides a Python client library for CrateDB.
+It implements the Python DB API 2.0 specification and includes support for
+SQLAlchemy.")
+ (license license:asl2.0)))