aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-06-13 16:06:20 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-07 15:48:19 +0200
commit0d5b7ea11f4b46197ede74e4b203244620dfd0f2 (patch)
tree1384b9b8ebb7050006bf44d835840b1c7acfb8f0
parent6543bc80b41c488a069b39d8b26e6d61cbb8252d (diff)
downloadguix-0d5b7ea11f4b46197ede74e4b203244620dfd0f2.tar
guix-0d5b7ea11f4b46197ede74e4b203244620dfd0f2.tar.gz
gnu: Add python-pytimeparse.
* gnu/packages/time.scm (python-pytimeparse): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/time.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 747e4cf080..a0c0824a92 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -65,6 +66,26 @@ program uses. The display output of the program can be customized or saved
to a file.")
(license gpl3+)))
+(define-public python-pytimeparse
+ (package
+ (name "python-pytimeparse")
+ (version "1.1.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytimeparse" version))
+ (sha256
+ (base32
+ "02kaambsgpjx3zi42j6l11rwms2p35b9hsk4f3kdf979gd3kcqg8"))))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (build-system python-build-system)
+ (home-page "https://github.com/wroberts/pytimeparse")
+ (synopsis "Time expression parser")
+ (description "This small Python module parses various kinds of time
+expressions.")
+ (license expat)))
+
(define-public python-pytzdata
(package
(name "python-pytzdata")