aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-08-15 14:07:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-08-20 09:20:19 +0300
commitf8f2a9449bb66abccb0a3c906c16ce020dececd0 (patch)
tree0ee11e98f9c2aab7129fca19182e5c9ef3814a6e
parentb035a10d5843976418754856837feb35f4606221 (diff)
downloadguix-f8f2a9449bb66abccb0a3c906c16ce020dececd0.tar
guix-f8f2a9449bb66abccb0a3c906c16ce020dececd0.tar.gz
gnu: monero: Update to 0.14.1.2.
* gnu/packages/finance.scm (monero): Update to 0.14.1.2. [arguments]: Add phase to make files writable for the tests. Enable a previously skipped test. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/finance.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7bfe5e62ff..fc26b77279 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -445,7 +445,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; the system's dynamically linked library.
(package
(name "monero")
- (version "0.14.1.0")
+ (version "0.14.1.2")
(source
(origin
(method git-fetch)
@@ -466,7 +466,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
#t))
(sha256
(base32
- "1asa197fad81jfv12qgaa7y7pdr1r1pda96m9pvivkh4v30cx0nh"))))
+ "00zl883c7lcd9z7g4y3vv7rxmr7ppzrxdblnhk32r9l3qzyw55r6"))))
(build-system cmake-build-system)
(native-inputs
`(("doxygen" ,doxygen)
@@ -508,6 +508,11 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
(("return \\(")
"return ((std::string(getenv(\"HOME\"))) / "))
#t))
+ (add-after 'change-log-path 'fix-file-permissions-for-tests
+ (lambda _
+ (for-each make-file-writable
+ (find-files "tests/data/" "wallet_9svHk1.*"))
+ #t))
;; Only try tests that don't need access to network or system
(replace 'check
(lambda _
@@ -522,11 +527,6 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
"DNSResolver.DNSSECSuccess"
"DNSResolver.DNSSECFailure"
"DNSResolver.GetTXTRecord"
- ;; TODO: Find why portability_wallet test fails
- ;; Maybe the Boost version used to create the test
- ;; wallet and the current Boost version are not
- ;; completely compatible?
- "Serialization.portability_wallet"
"is_hdd.linux_os_root")
":")))
(invoke "tests/unit_tests/unit_tests"