aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-14 06:35:31 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 15:56:30 +0300
commite076ca86dba3ef344d0d3907a808698ae8211b35 (patch)
treeb5105241f775b7ada2a185cdca549a0aa8708bb3
parent44e8358298833097476238f3481b4b28dcf16a00 (diff)
downloadguix-e076ca86dba3ef344d0d3907a808698ae8211b35.tar
guix-e076ca86dba3ef344d0d3907a808698ae8211b35.tar.gz
gnu: Add emacs-phi-search.
* gnu/packages/emacs-xyz.scm (emacs-phi-search): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4a8820f405..7ed341885d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3460,6 +3460,28 @@ completion candidate when using the Company text completion framework.")
a customizable list.")
(license license:gpl3+))))
+(define-public emacs-phi-search
+ (let ((commit "9a089b8271cb1cff9640848850298c9ec855286c")
+ (revision "1"))
+ (package
+ (name "emacs-phi-search")
+ (version (git-version "20160630" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zk-phi/phi-search.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gr5plcbrfdc4pglfj905s89hf8x0kc083h30wcnd81bnw9jwz1x"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/zk-phi/phi-search")
+ (synopsis "Interactive search compatible with @code{multiple-cursors}")
+ (description "This package can be used with @code{multiple-cursors} to
+provide an incremental search that moves all fake cursors in sync.")
+ (license license:gpl2+))))
+
(define-public emacs-multiple-cursors
(package
(name "emacs-multiple-cursors")