aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-20 01:53:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-08-20 01:53:49 +0200
commitdfe8a7048e036a6d702edfd133a4ead5e879e3cf (patch)
tree624e8972aec4f488843948588faf3f0035c43025
parent2bdb5716d87908c3164471ad25c398768204fb5d (diff)
downloadguix-dfe8a7048e036a6d702edfd133a4ead5e879e3cf.tar
guix-dfe8a7048e036a6d702edfd133a4ead5e879e3cf.tar.gz
gnu: Add python-folium.
* gnu/packages/python-xyz.scm (python-folium): New variable.
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 459d5d44e1..6f4c3b79d0 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16058,3 +16058,34 @@ one-off scripts.")
time-or-computationally-expensive properties quick and easy and works in Python
2 or 3.")
(license license:bsd-3)))
+
+(define-public python-folium
+ (package
+ (name "python-folium")
+ (version "0.10.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "folium" version))
+ (sha256
+ (base32
+ "18fzxijsgrb95r0a8anc9ba5ijyw3nlnv3rpavfbkqa5v878x84f"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-branca" ,python-branca)
+ ("python-jinja2" ,python-jinja2)
+ ("python-numpy" ,python-numpy)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/python-visualization/folium")
+ (synopsis "Make beautiful maps with Leaflet.js & Python")
+ (description "@code{folium} makes it easy to visualize data that’s been
+manipulated in Python on an interactive leaflet map. It enables both the
+binding of data to a map for @code{choropleth} visualizations as well as
+passing rich vector/raster/HTML visualizations as markers on the map.
+
+The library has a number of built-in tilesets from OpenStreetMap, Mapbox, and
+Stamen, and supports custom tilesets with Mapbox or Cloudmade API keys. It
+supports Image, Video, GeoJSON and TopoJSON overlays.")
+ (license license:expat)))