aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-07-21 16:56:44 +0200
committerJelle Licht <jlicht@fsfe.org>2019-08-21 14:15:22 +0200
commitc8c42d878618271a3db4fd8c1cb11f15aa38f452 (patch)
tree3d6a4d923b6d6e82b6205a1ba201896b83d2ee43
parente6b7f90ebaabe000274c9a157c29b20f4f86a3fb (diff)
downloadguix-c8c42d878618271a3db4fd8c1cb11f15aa38f452.tar
guix-c8c42d878618271a3db4fd8c1cb11f15aa38f452.tar.gz
gnu: Add emacs-ssh-config-mode.
* gnu/packages/emacs-xyz.scm (emacs-ssh-config-mode): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6ea851187c..2f5bf05ff9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17635,3 +17635,31 @@ JIRA issue servers.")
(description
"Major mode for editing systemd units in GNU Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-ssh-config-mode
+ (let ((commit "4c1dfa57d452cb5654453bf186c8ff63e1e71b56")
+ (revision "1"))
+ (package
+ (name "emacs-ssh-config-mode")
+ (version (git-version "8.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/jhgorrell/ssh-config-mode-el.git")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "0crglfdazzckizbwzmgl2rn6j85avfzkr1q7ijxd17rp2anvr9bd"))))
+ (build-system emacs-build-system)
+ (arguments '(#:include '("\\.el$" "\\.txt$")))
+ (home-page
+ "https://github.com/jhgorrell/ssh-config-mode-el")
+ (synopsis
+ "Mode for fontification of ~/.ssh/config")
+ (description
+ "This packages fontifies the ssh config keywords and creates
+keybindings for skipping from host section to host section.")
+ (license license:gpl3+))))