aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-17 06:15:54 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 20:37:23 +0300
commit64cd8e838a46ba30766eb44fe06f792237c99d01 (patch)
tree9f037038984c27627ebd051a32851ebc318eeec4
parent49b28a740bcdb906245b1405f7dc91efeee621a3 (diff)
downloadguix-64cd8e838a46ba30766eb44fe06f792237c99d01.tar
guix-64cd8e838a46ba30766eb44fe06f792237c99d01.tar.gz
gnu: Add emacs-org-rich-yank.
* gnu/packages/emacs-xyz.scm (emacs-org-rich-yank): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index adab7d87d2..324b8a6073 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2729,6 +2729,29 @@ naming style of a symbol. It supports different naming conventions such as:
tables.")
(license license:gpl2+)))
+(define-public emacs-org-rich-yank
+ (package
+ (name "emacs-org-rich-yank")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/unhammer/org-rich-yank.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0gxb0fnh5gxjmld0hnk5hli0cvdd8gjd27m30bk2b80kwldxlq1z"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/unhammer/org-rich-yank")
+ (synopsis "Automatically surround source code pasted into Org with
+@code{#+BEGIN_SRC} blocks")
+ (description
+ "This package provides a utility function for Org buffers that makes a
+@code{_SRC} block with the appropriate language annotation for code that has
+been copied from an Emacs major mode.")
+ (license license:gpl2+)))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")