aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-19 16:15:09 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-08-20 21:50:29 -0400
commit64c70430ec80c93faff6139fdb9d3de92704b81e (patch)
treed78cda485a152997e6f7f88d95ce2aff829ec53c
parent5485148c76e178c9e9ae6d8ecb5f948e0c12028f (diff)
downloadguix-64c70430ec80c93faff6139fdb9d3de92704b81e.tar
guix-64c70430ec80c93faff6139fdb9d3de92704b81e.tar.gz
gnu: gnome-control-center: Fix info-overview panel issues.
GNOME Control Center should now display the correct GNOME version and graphics information in the "Details > About" panel. * gnu/packages/gnome.scm (gnome-control-center)[arguments]: Add configure flag. Adjust 'patch-paths' phase accordingly. [inputs]: Add gnome-session.
-rw-r--r--gnu/packages/gnome.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d5e46e09c1..bfc055eed4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5967,7 +5967,10 @@ devices using the GNOME desktop.")
(arguments
'(#:glib-or-gtk? #t
#:configure-flags
- (list "-Dcheese=false")
+ (list "-Dcheese=false"
+ (string-append "-Dgnome_session_libexecdir="
+ (assoc-ref %build-inputs "gnome-session")
+ "/libexec"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
@@ -5975,7 +5978,8 @@ devices using the GNOME desktop.")
(let ((libc (assoc-ref inputs "libc"))
(tzdata (assoc-ref inputs "tzdata"))
(libgnomekbd (assoc-ref inputs "libgnomekbd"))
- (nm-applet (assoc-ref inputs "network-manager-applet")))
+ (nm-applet (assoc-ref inputs "network-manager-applet"))
+ (gnome-desktop (assoc-ref inputs "gnome-desktop")))
(substitute* "panels/datetime/tz.h"
(("/usr/share/zoneinfo/zone.tab")
(string-append tzdata "/share/zoneinfo/zone.tab")))
@@ -5995,6 +5999,10 @@ devices using the GNOME desktop.")
(substitute* '("panels/user-accounts/run-passwd.c")
(("/usr/bin/passwd")
"/run/setuid-programs/passwd"))
+ (substitute* "panels/info/cc-info-overview-panel.c"
+ (("DATADIR \"/gnome/gnome-version.xml\"")
+ (string-append "\"" gnome-desktop
+ "/share/gnome/gnome-version.xml\"")))
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
@@ -6014,6 +6022,7 @@ devices using the GNOME desktop.")
("gnome-desktop" ,gnome-desktop)
("gnome-online-accounts" ,gnome-online-accounts)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("gnome-session" ,gnome-session)
("gnome-settings-daemon" ,gnome-settings-daemon)
("grilo" ,grilo)
("ibus" ,ibus)