aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-17 06:59:48 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 20:53:02 +0300
commit3eb245434be62ed59f7901469472d5390e07433a (patch)
tree90176c27231ebed796441b088dd6450bce948dba
parent3615e9e6c53c8924c23c903d62615ba609f7697c (diff)
downloadguix-3eb245434be62ed59f7901469472d5390e07433a.tar
guix-3eb245434be62ed59f7901469472d5390e07433a.tar.gz
gnu: Add emacs-org-now.
* gnu/packages/emacs-xyz.scm (emacs-org-now): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b393a2d88c..df89aebb3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2775,6 +2775,32 @@ been copied from an Emacs major mode.")
"This package integrates @code{restclient-mode} with Org.")
(license license:gpl3+))))
+(define-public emacs-org-now
+ (let ((commit "8f6b277a73f1c66e58ccb4b7f40d406851befc91"))
+ (package
+ (name "emacs-org-now")
+ (version (git-version "0.1-pre" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/org-now.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117zzkryznznk6h4i1jqzdn888nl019xrgxm2gza0lndx8dxsg2c"))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/alphapapa/org-now")
+ (synopsis "Show current Org tasks in a sidebar")
+ (description
+ "This package provides commands to show Org headings in a sidebar
+window while working on them. After defining one heading as the \"now\"
+heading, other headings can be refiled to it with one command, and back to
+their original location with another.")
+ (license license:gpl3+))))
+
(define-public emacs-rich-minority
(package
(name "emacs-rich-minority")