aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-08-18 03:01:41 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-08-18 21:00:26 +0300
commit317879f555ac945c89423c178e280482f4b1d83d (patch)
tree9228dae65c39d15f587923440cefc454cb49bd7a
parenteff412ed3b7add0a32fdf681950fa1e791d4af04 (diff)
downloadguix-317879f555ac945c89423c178e280482f4b1d83d.tar
guix-317879f555ac945c89423c178e280482f4b1d83d.tar.gz
gnu: Add emacs-frog-menu.
* gnu/packages/emacs-xyz.scm (emacs-frog-menu): New variable. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a4708a1d85..4444690e3f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10223,6 +10223,33 @@ environment variables to be retrieved from the shell, so that Emacs will see
the same values you get in a terminal.")
(license license:gpl3+)))
+(define-public emacs-frog-menu
+ (let ((commit "740bbc88b8535d31f783f3b2043a2a6683afbf31")
+ (revision "1"))
+ (package
+ (name "emacs-frog-menu")
+ (version (git-version "0.2.9" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clemera/frog-menu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g77424jwq62qj06rvld44s5hp0dw8rw2pwmmag6gd536zf65xrj"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-posframe" ,emacs-posframe)
+ ("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/clemera/frog-menu")
+ (synopsis "Quickly pick items from ad hoc menus")
+ (description
+ "This package provides a popup offering a preview of a list of
+candidates on which user-defined dispatch actions can act.")
+ (license license:gpl3+))))
+
(define-public emacs-deft
(package
(name "emacs-deft")