aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2019-07-21 16:55:59 +0200
committerJelle Licht <jlicht@fsfe.org>2019-08-21 14:14:47 +0200
commit0f4e4d8ff0e91396985b66a7b3b4ba3cdc0eed07 (patch)
tree746cbb69f8cfeff9967ac7dca6d926e8f7ff14c2
parent8d3bc0f16508a5d76351245fbd08e930fcf5e586 (diff)
downloadguix-0f4e4d8ff0e91396985b66a7b3b4ba3cdc0eed07.tar
guix-0f4e4d8ff0e91396985b66a7b3b4ba3cdc0eed07.tar.gz
gnu: Add emacs-org-emms.
* gnu/packages/emacs-xyz.scm (emacs-org-emms): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a4a2164354..d3fcdaeb15 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17557,3 +17557,32 @@ a variety of languages, including elisp itself.")
interfaces. Several interfaces are supported beside the classic ido: popup,
helm and ivy.")
(license license:gpl3+)))
+
+(define-public emacs-org-emms
+ (let ((commit "07a8917f3d628c32e5de1dbd118ac08203772533")
+ (revision "1"))
+ (package
+ (name "emacs-org-emms")
+ (version
+ (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/jagrg/org-emms.git")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "1sqsm5sv311xfdk4f4rsnvprdf2v2vm7l1b3vqi7pc0g8adlnw1d"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emms" ,emacs-emms)
+ ("emacs-org" ,emacs-org)))
+ (home-page "https://gitlab.com/jagrg/org-emms")
+ (synopsis "Play multimedia files from org-mode")
+ (description
+ "This package provides a new org link type for playing back multimedia
+files from org-mode using EMMS, The Emacs Multimedia System. If the link
+contains a track position, playback will start at the specified position.")
+ (license license:gpl3+))))